Aerogear UPS 1.1.0.Final installation error: AbstractServiceCache is not proxyable

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Aerogear UPS 1.1.0.Final installation error: AbstractServiceCache is not proxyable

jeff01
This post was updated on .
Hi,

I have a question regarding Aerogear UPS 1.1.0.Final installation. I got an exception in the log:

^[[0m^[[31m21:28:29,448 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-1) MSC000001: Failed to start service jboss.deployment.unit."unifiedpush-server-as7.war".WeldStartService: org.jboss.msc.service.StartException in service jboss.deployment.unit."unifiedpush-server-as7.war".WeldStartService: Failed to start service
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1767) [jboss-msc.jar:1.0.4.GA-redhat-1]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_75]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_75]
        at java.lang.Thread.run(Thread.java:745) [rt.jar:1.7.0_75]
Caused by: org.jboss.weld.exceptions.UnproxyableResolutionException: WELD-001435 Normal scoped bean class org.jboss.aerogear.unifiedpush.message.cache.AbstractServiceCache is not proxyable because it has no no-args constructor - Managed Bean [class org.jboss.aerogear.unifiedpush.message.cache.ApnsServiceCache] with qualifiers [@Any @Default].
        at org.jboss.weld.util.Proxies.getUnproxyableClassException(Proxies.java:214)
        at org.jboss.weld.util.Proxies.getUnproxyableTypeException(Proxies.java:184)
        at org.jboss.weld.util.Proxies.getUnproxyableTypesExceptionInt(Proxies.java:195)
        at org.jboss.weld.util.Proxies.getUnproxyableTypesException(Proxies.java:169)
        at org.jboss.weld.bootstrap.Validator.validateBean(Validator.java:147)
        at org.jboss.weld.bootstrap.Validator.validateRIBean(Validator.java:163)
        at org.jboss.weld.bootstrap.Validator.validateBeans(Validator.java:382)
        at org.jboss.weld.bootstrap.Validator.validateDeployment(Validator.java:367)
        at org.jboss.weld.bootstrap.WeldBootstrap.validateBeans(WeldBootstrap.java:379)
        at org.jboss.as.weld.WeldStartService.start(WeldStartService.java:64)
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc.jar:1.0.4.GA-redhat-1]
        at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc.jar:1.0.4.GA-redhat-1]
        ... 3 more


Can anyone shed some light on what's going on? That's a fresh install on JBoss running openJDK 1.7.

Could the root cause be that our JBoss version is too low? What is JBoss version requirement for installing Aerogear UPS 1.1.0.Final? In different places, AeroGear documentation refers to different versions of JBoss for this version of Aerogear UPS: JBoss EAP 6.4.0 GA, or Jboss EAP 6.3. But I am not sure if this is the minimum version of JBoss to run AeroGeear UPS 1.1.0.Final.

Our JBoss: JBoss MSC version 1.0.4.GA-redhat-1, JBoss EAP 6.1.1.GA.

Did any of you run AeroGeear UPS 1.1.0.Final successfully in this or similar versions of JBoss EAP?


Thank you.
Reply | Threaded
Open this post in threaded view
|

Re: Aerogear UPS 1.1.0.Final installation error: AbstractServiceCache is not proxyable

jeff01
Anyone experienced this and can help?

Thanks in advance.
Reply | Threaded
Open this post in threaded view
|

Re: Aerogear UPS 1.1.0.Final installation error: AbstractServiceCache is not proxyable

jeff01
In reply to this post by jeff01
In other words, has anyone successfully run AeroGear 1.1.0.Final on Jboss EAP 6.1.0?
Reply | Threaded
Open this post in threaded view
|

Re: [Aerogear-users] Aerogear UPS 1.1.0.Final installation error: AbstractServiceCache is not proxyable

Matthias Wessendorf
Hello jeff01,

unfortunately the UPS is not supporting running on JBoss AS7, or EAP 6.1.

We do require WildFly-8 or for EAP 6.4.0:

Cheers,
Matthias

On Thu, Nov 12, 2015 at 10:07 PM, jeff01 <[hidden email]> wrote:
In other words, has anyone successfully run AeroGear 1.1.0.Final on Jboss EAP
6.1.0?



--
View this message in context: http://aerogear-users.1116366.n5.nabble.com/Aerogear-UPS-1-1-0-Final-installation-error-AbstractServiceCache-is-not-proxyable-tp269p275.html
Sent from the aerogear-users mailing list archive at Nabble.com.
_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users



--

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users