[Aerogear-users] Cannot build cordova project with aerogear push plugin

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Aerogear-users] Cannot build cordova project with aerogear push plugin

Fabio Turizo
I haven't been capable of building a cordova project for android using the cordova aerogear plugin. First, the plugin is installed like this:


And the plugin is installed succesfully:

Repository "https://github.com/aerogear/aerogear-pushplugin-cordova.git" checked out to git ref "master".
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to git ref "master".

However when building for Android i always get the following errors:

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'android'.
> Could not resolve all dependencies for configuration ':_debugCompile'.
   > Could not find any version that matches com.android.support:appcompat-v7:22.+.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-core:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-pipe:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-push:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified

I tried unistalling cordova and npm, but to no avail i haven't been capable of building an app that uses AeroGear.

Any assistance is gladly welcome.

P.S: Using Cordova 5.1.1 for Android 5.1



_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Cannot build cordova project with aerogear push plugin

Sebastien Blanc
Hi !
The plugin from GitHub master relies on an aerogear android library with a snapshot version that is not on maven. 
The easiest way is to install the plugin  from cordova's registry :

cordova plugin add org.jboss.aerogear.cordova.push

If you really need the master version of the plugi. You will need to build all the android lib locally.
Sebi


Envoyé de mon iPhone

Le 22 juin 2015 à 02:34, Fabio Turizo <[hidden email]> a écrit :

I haven't been capable of building a cordova project for android using the cordova aerogear plugin. First, the plugin is installed like this:


And the plugin is installed succesfully:

Repository "https://github.com/aerogear/aerogear-pushplugin-cordova.git" checked out to git ref "master".
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to git ref "master".

However when building for Android i always get the following errors:

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'android'.
> Could not resolve all dependencies for configuration ':_debugCompile'.
   > Could not find any version that matches com.android.support:appcompat-v7:22.+.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-core:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-pipe:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-push:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified

I tried unistalling cordova and npm, but to no avail i haven't been capable of building an app that uses AeroGear.

Any assistance is gladly welcome.

P.S: Using Cordova 5.1.1 for Android 5.1


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Cannot build cordova project with aerogear push plugin

Fabio Turizo
I tried installing the plugin as you instructed, but i get the following error:

WARNING: org.jboss.aerogear.cordova.push has been renamed to aerogear-cordova-push. You may not be getting the latest version! We suggest you `cordova plugin rm org.jboss.aerogear.cordova.push` and `cordova plugin add aerogear-cordova-push`.
Fetching plugin "org.jboss.aerogear.cordova.push" via cordova plugins registry
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to git ref "master".
Installing "com.vladstirbu.cordova.promise" for android
Failed to install 'org.jboss.aerogear.cordova.push':Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)

I'm getting this error in multiple workstations, so i'm assuming the plugin installation has issues.

El dom., 21 de jun. de 2015 a la(s) 11:32 p. m., Sébastien Blanc <[hidden email]> escribió:
Hi !
The plugin from GitHub master relies on an aerogear android library with a snapshot version that is not on maven. 
The easiest way is to install the plugin  from cordova's registry :

cordova plugin add org.jboss.aerogear.cordova.push

If you really need the master version of the plugi. You will need to build all the android lib locally.
Sebi


Envoyé de mon iPhone

Le 22 juin 2015 à 02:34, Fabio Turizo <[hidden email]> a écrit :

I haven't been capable of building a cordova project for android using the cordova aerogear plugin. First, the plugin is installed like this:


And the plugin is installed succesfully:

Repository "https://github.com/aerogear/aerogear-pushplugin-cordova.git" checked out to git ref "master".
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to git ref "master".

However when building for Android i always get the following errors:

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'android'.
> Could not resolve all dependencies for configuration ':_debugCompile'.
   > Could not find any version that matches com.android.support:appcompat-v7:22.+.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-core:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-pipe:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-push:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified

I tried unistalling cordova and npm, but to no avail i haven't been capable of building an app that uses AeroGear.

Any assistance is gladly welcome.

P.S: Using Cordova 5.1.1 for Android 5.1


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Cannot build cordova project with aerogear push plugin

Sebastien Blanc
Did you do what they suggested you in the error mesage : 
"
We suggest you `cordova plugin rm org.jboss.aerogear.cordova.push` and `cordova plugin add aerogear-cordova-push`.




On Mon, Jun 22, 2015 at 3:26 PM, Fabio Turizo <[hidden email]> wrote:
I tried installing the plugin as you instructed, but i get the following error:

WARNING: org.jboss.aerogear.cordova.push has been renamed to aerogear-cordova-push. You may not be getting the latest version! We suggest you `cordova plugin rm org.jboss.aerogear.cordova.push` and `cordova plugin add aerogear-cordova-push`.
Fetching plugin "org.jboss.aerogear.cordova.push" via cordova plugins registry
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to git ref "master".
Installing "com.vladstirbu.cordova.promise" for android
Failed to install 'org.jboss.aerogear.cordova.push':Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)

I'm getting this error in multiple workstations, so i'm assuming the plugin installation has issues.

El dom., 21 de jun. de 2015 a la(s) 11:32 p. m., Sébastien Blanc <[hidden email]> escribió:
Hi !
The plugin from GitHub master relies on an aerogear android library with a snapshot version that is not on maven. 
The easiest way is to install the plugin  from cordova's registry :

cordova plugin add org.jboss.aerogear.cordova.push

If you really need the master version of the plugi. You will need to build all the android lib locally.
Sebi


Envoyé de mon iPhone

Le 22 juin 2015 à 02:34, Fabio Turizo <[hidden email]> a écrit :

I haven't been capable of building a cordova project for android using the cordova aerogear plugin. First, the plugin is installed like this:


And the plugin is installed succesfully:

Repository "https://github.com/aerogear/aerogear-pushplugin-cordova.git" checked out to git ref "master".
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to git ref "master".

However when building for Android i always get the following errors:

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'android'.
> Could not resolve all dependencies for configuration ':_debugCompile'.
   > Could not find any version that matches com.android.support:appcompat-v7:22.+.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-core:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-pipe:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-push:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified

I tried unistalling cordova and npm, but to no avail i haven't been capable of building an app that uses AeroGear.

Any assistance is gladly welcome.

P.S: Using Cordova 5.1.1 for Android 5.1


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users



_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Cannot build cordova project with aerogear push plugin

Fabio Turizo
In reply to this post by Fabio Turizo
I also tried to install it on another workstation with cordova v4.3.0, and it worked:

Fetching plugin "org.jboss.aerogear.cordova.push" via plugin registry
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Installing "com.vladstirbu.cordova.promise" for android
Installing "android.support.v4" for android
Installing "com.google.playservices" for android

Checking the plugin list:

org.jboss.aerogear.cordova.push 1.0.2 "
    AeroGear PushPlugin
  "

El lun., 22 de jun. de 2015 a la(s) 8:24 a. m., Fabio Turizo <[hidden email]> escribió:
I tried installing the plugin as you instructed, but i get the following error:

WARNING: org.jboss.aerogear.cordova.push has been renamed to aerogear-cordova-push. You may not be getting the latest version! We suggest you `cordova plugin rm org.jboss.aerogear.cordova.push` and `cordova plugin add aerogear-cordova-push`.
Fetching plugin "org.jboss.aerogear.cordova.push" via cordova plugins registry
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to git ref "master".
Installing "com.vladstirbu.cordova.promise" for android
Failed to install 'org.jboss.aerogear.cordova.push':Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)

I'm getting this error in multiple workstations, so i'm assuming the plugin installation has issues.

El dom., 21 de jun. de 2015 a la(s) 11:32 p. m., Sébastien Blanc <[hidden email]> escribió:
Hi !
The plugin from GitHub master relies on an aerogear android library with a snapshot version that is not on maven. 
The easiest way is to install the plugin  from cordova's registry :

cordova plugin add org.jboss.aerogear.cordova.push

If you really need the master version of the plugi. You will need to build all the android lib locally.
Sebi


Envoyé de mon iPhone

Le 22 juin 2015 à 02:34, Fabio Turizo <[hidden email]> a écrit :

I haven't been capable of building a cordova project for android using the cordova aerogear plugin. First, the plugin is installed like this:


And the plugin is installed succesfully:

Repository "https://github.com/aerogear/aerogear-pushplugin-cordova.git" checked out to git ref "master".
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to git ref "master".

However when building for Android i always get the following errors:

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'android'.
> Could not resolve all dependencies for configuration ':_debugCompile'.
   > Could not find any version that matches com.android.support:appcompat-v7:22.+.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-core:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-pipe:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-push:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified

I tried unistalling cordova and npm, but to no avail i haven't been capable of building an app that uses AeroGear.

Any assistance is gladly welcome.

P.S: Using Cordova 5.1.1 for Android 5.1


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Cannot build cordova project with aerogear push plugin

Fabio Turizo
Tried the instruction in the warning, same result:

Fetching plugin "aerogear-cordova-push" via npm
Installing "org.jboss.aerogear.cordova.push" for android
Failed to install 'org.jboss.aerogear.cordova.push':Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434981713451'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434981713451'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)


El lun., 22 de jun. de 2015 a la(s) 9:01 a. m., Fabio Turizo <[hidden email]> escribió:
I also tried to install it on another workstation with cordova v4.3.0, and it worked:

Fetching plugin "org.jboss.aerogear.cordova.push" via plugin registry
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Installing "com.vladstirbu.cordova.promise" for android
Installing "android.support.v4" for android
Installing "com.google.playservices" for android

Checking the plugin list:

org.jboss.aerogear.cordova.push 1.0.2 "
    AeroGear PushPlugin
  "

El lun., 22 de jun. de 2015 a la(s) 8:24 a. m., Fabio Turizo <[hidden email]> escribió:
I tried installing the plugin as you instructed, but i get the following error:

WARNING: org.jboss.aerogear.cordova.push has been renamed to aerogear-cordova-push. You may not be getting the latest version! We suggest you `cordova plugin rm org.jboss.aerogear.cordova.push` and `cordova plugin add aerogear-cordova-push`.
Fetching plugin "org.jboss.aerogear.cordova.push" via cordova plugins registry
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to git ref "master".
Installing "com.vladstirbu.cordova.promise" for android
Failed to install 'org.jboss.aerogear.cordova.push':Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)

I'm getting this error in multiple workstations, so i'm assuming the plugin installation has issues.

El dom., 21 de jun. de 2015 a la(s) 11:32 p. m., Sébastien Blanc <[hidden email]> escribió:
Hi !
The plugin from GitHub master relies on an aerogear android library with a snapshot version that is not on maven. 
The easiest way is to install the plugin  from cordova's registry :

cordova plugin add org.jboss.aerogear.cordova.push

If you really need the master version of the plugi. You will need to build all the android lib locally.
Sebi


Envoyé de mon iPhone

Le 22 juin 2015 à 02:34, Fabio Turizo <[hidden email]> a écrit :

I haven't been capable of building a cordova project for android using the cordova aerogear plugin. First, the plugin is installed like this:


And the plugin is installed succesfully:

Repository "https://github.com/aerogear/aerogear-pushplugin-cordova.git" checked out to git ref "master".
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to git ref "master".

However when building for Android i always get the following errors:

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'android'.
> Could not resolve all dependencies for configuration ':_debugCompile'.
   > Could not find any version that matches com.android.support:appcompat-v7:22.+.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-core:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-pipe:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-push:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified

I tried unistalling cordova and npm, but to no avail i haven't been capable of building an app that uses AeroGear.

Any assistance is gladly welcome.

P.S: Using Cordova 5.1.1 for Android 5.1


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Cannot build cordova project with aerogear push plugin

Sebastien Blanc
Hum, so looks like we have an issue wiuth corova 5.x , could you open a jira here : https://issues.jboss.org/browse/AGCORDOVA
I'm sure Erik will be able to help you but is out now for conferences this week.


On Mon, Jun 22, 2015 at 4:04 PM, Fabio Turizo <[hidden email]> wrote:
Tried the instruction in the warning, same result:

Fetching plugin "aerogear-cordova-push" via npm
Installing "org.jboss.aerogear.cordova.push" for android
Failed to install 'org.jboss.aerogear.cordova.push':Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434981713451'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434981713451'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)


El lun., 22 de jun. de 2015 a la(s) 9:01 a. m., Fabio Turizo <[hidden email]> escribió:
I also tried to install it on another workstation with cordova v4.3.0, and it worked:

Fetching plugin "org.jboss.aerogear.cordova.push" via plugin registry
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Installing "com.vladstirbu.cordova.promise" for android
Installing "android.support.v4" for android
Installing "com.google.playservices" for android

Checking the plugin list:

org.jboss.aerogear.cordova.push 1.0.2 "
    AeroGear PushPlugin
  "

El lun., 22 de jun. de 2015 a la(s) 8:24 a. m., Fabio Turizo <[hidden email]> escribió:
I tried installing the plugin as you instructed, but i get the following error:

WARNING: org.jboss.aerogear.cordova.push has been renamed to aerogear-cordova-push. You may not be getting the latest version! We suggest you `cordova plugin rm org.jboss.aerogear.cordova.push` and `cordova plugin add aerogear-cordova-push`.
Fetching plugin "org.jboss.aerogear.cordova.push" via cordova plugins registry
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to git ref "master".
Installing "com.vladstirbu.cordova.promise" for android
Failed to install 'org.jboss.aerogear.cordova.push':Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)

I'm getting this error in multiple workstations, so i'm assuming the plugin installation has issues.

El dom., 21 de jun. de 2015 a la(s) 11:32 p. m., Sébastien Blanc <[hidden email]> escribió:
Hi !
The plugin from GitHub master relies on an aerogear android library with a snapshot version that is not on maven. 
The easiest way is to install the plugin  from cordova's registry :

cordova plugin add org.jboss.aerogear.cordova.push

If you really need the master version of the plugi. You will need to build all the android lib locally.
Sebi


Envoyé de mon iPhone

Le 22 juin 2015 à 02:34, Fabio Turizo <[hidden email]> a écrit :

I haven't been capable of building a cordova project for android using the cordova aerogear plugin. First, the plugin is installed like this:


And the plugin is installed succesfully:

Repository "https://github.com/aerogear/aerogear-pushplugin-cordova.git" checked out to git ref "master".
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to git ref "master".

However when building for Android i always get the following errors:

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'android'.
> Could not resolve all dependencies for configuration ':_debugCompile'.
   > Could not find any version that matches com.android.support:appcompat-v7:22.+.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-core:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-pipe:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-push:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified

I tried unistalling cordova and npm, but to no avail i haven't been capable of building an app that uses AeroGear.

Any assistance is gladly welcome.

P.S: Using Cordova 5.1.1 for Android 5.1


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users



_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Cannot build cordova project with aerogear push plugin

Fabio Turizo
Ok, done it. Reported it in this issue: https://issues.jboss.org/browse/AGCORDOVA-107

El lun., 22 de jun. de 2015 a la(s) 10:29 a. m., Sebastien Blanc <[hidden email]> escribió:
Hum, so looks like we have an issue wiuth corova 5.x , could you open a jira here : https://issues.jboss.org/browse/AGCORDOVA
I'm sure Erik will be able to help you but is out now for conferences this week.


On Mon, Jun 22, 2015 at 4:04 PM, Fabio Turizo <[hidden email]> wrote:
Tried the instruction in the warning, same result:

Fetching plugin "aerogear-cordova-push" via npm
Installing "org.jboss.aerogear.cordova.push" for android
Failed to install 'org.jboss.aerogear.cordova.push':Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434981713451'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434981713451'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)


El lun., 22 de jun. de 2015 a la(s) 9:01 a. m., Fabio Turizo <[hidden email]> escribió:
I also tried to install it on another workstation with cordova v4.3.0, and it worked:

Fetching plugin "org.jboss.aerogear.cordova.push" via plugin registry
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Installing "com.vladstirbu.cordova.promise" for android
Installing "android.support.v4" for android
Installing "com.google.playservices" for android

Checking the plugin list:

org.jboss.aerogear.cordova.push 1.0.2 "
    AeroGear PushPlugin
  "

El lun., 22 de jun. de 2015 a la(s) 8:24 a. m., Fabio Turizo <[hidden email]> escribió:
I tried installing the plugin as you instructed, but i get the following error:

WARNING: org.jboss.aerogear.cordova.push has been renamed to aerogear-cordova-push. You may not be getting the latest version! We suggest you `cordova plugin rm org.jboss.aerogear.cordova.push` and `cordova plugin add aerogear-cordova-push`.
Fetching plugin "org.jboss.aerogear.cordova.push" via cordova plugins registry
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to git ref "master".
Installing "com.vladstirbu.cordova.promise" for android
Failed to install 'org.jboss.aerogear.cordova.push':Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
warning: Could not find remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in upstream origin
Unexpected end of command stream
    at ChildProcess.whenDone (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)

I'm getting this error in multiple workstations, so i'm assuming the plugin installation has issues.

El dom., 21 de jun. de 2015 a la(s) 11:32 p. m., Sébastien Blanc <[hidden email]> escribió:
Hi !
The plugin from GitHub master relies on an aerogear android library with a snapshot version that is not on maven. 
The easiest way is to install the plugin  from cordova's registry :

cordova plugin add org.jboss.aerogear.cordova.push

If you really need the master version of the plugi. You will need to build all the android lib locally.
Sebi


Envoyé de mon iPhone

Le 22 juin 2015 à 02:34, Fabio Turizo <[hidden email]> a écrit :

I haven't been capable of building a cordova project for android using the cordova aerogear plugin. First, the plugin is installed like this:


And the plugin is installed succesfully:

Repository "https://github.com/aerogear/aerogear-pushplugin-cordova.git" checked out to git ref "master".
Installing "org.jboss.aerogear.cordova.push" for android
Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git clone
Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to git ref "master".

However when building for Android i always get the following errors:

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring root project 'android'.
> Could not resolve all dependencies for configuration ':_debugCompile'.
   > Could not find any version that matches com.android.support:appcompat-v7:22.+.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-core:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-pipe:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified
   > Could not find org.jboss.aerogear:aerogear-android-push:2.2.0-SNAPSHOT.
     Searched in the following locations:
     Required by:
         :android:unspecified

I tried unistalling cordova and npm, but to no avail i haven't been capable of building an app that uses AeroGear.

Any assistance is gladly welcome.

P.S: Using Cordova 5.1.1 for Android 5.1


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Cannot build cordova project with aerogear push plugin

Erik Jan de Wit
In reply to this post by Fabio Turizo
seems that it can't get one of the plugin dependencies with git
(cordova-plugin-android-support-v4) we depend on this plugin with a
fixed commit because it doesn't have any tags or releases. Now it
seems that the commit we depend on is no longer there. We need to
release another version of the plugin to fix this.

On Mon, Jun 22, 2015 at 3:26 PM, Fabio Turizo <[hidden email]> wrote:

> I tried installing the plugin as you instructed, but i get the following
> error:
>
> WARNING: org.jboss.aerogear.cordova.push has been renamed to
> aerogear-cordova-push. You may not be getting the latest version! We suggest
> you `cordova plugin rm org.jboss.aerogear.cordova.push` and `cordova plugin
> add aerogear-cordova-push`.
> Fetching plugin "org.jboss.aerogear.cordova.push" via cordova plugins
> registry
> npm http GET http://registry.cordova.io/org.jboss.aerogear.cordova.push
> npm http 304 http://registry.cordova.io/org.jboss.aerogear.cordova.push
> Installing "org.jboss.aerogear.cordova.push" for android
> Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git
> clone
> Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to
> git ref "master".
> Installing "com.vladstirbu.cordova.promise" for android
> Fetching plugin
> "https://github.com/MobileChromeApps/cordova-plugin-android-support-v4" via
> git clone
> Failed to install 'org.jboss.aerogear.cordova.push':Error: C:\Program Files
> (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
> Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
> warning: Could not find remote branch
> 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
> fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in
> upstream origin
> Unexpected end of command stream
>     at ChildProcess.whenDone
> (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
>     at ChildProcess.emit (events.js:110:17)
>     at maybeClose (child_process.js:1015:16)
>     at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
> Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code
> 128 Error output:
> Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
> warning: Could not find remote branch
> 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
> fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in
> upstream origin
> Unexpected end of command stream
>     at ChildProcess.whenDone
> (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
>     at ChildProcess.emit (events.js:110:17)
>     at maybeClose (child_process.js:1015:16)
>     at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
>
> I'm getting this error in multiple workstations, so i'm assuming the plugin
> installation has issues.
>
> El dom., 21 de jun. de 2015 a la(s) 11:32 p. m., Sébastien Blanc
> <[hidden email]> escribió:
>>
>> Hi !
>> The plugin from GitHub master relies on an aerogear android library with a
>> snapshot version that is not on maven.
>> The easiest way is to install the plugin  from cordova's registry :
>>
>> cordova plugin add org.jboss.aerogear.cordova.push
>>
>> If you really need the master version of the plugi. You will need to build
>> all the android lib locally.
>> Sebi
>>
>>
>> Envoyé de mon iPhone
>>
>> Le 22 juin 2015 à 02:34, Fabio Turizo <[hidden email]> a écrit :
>>
>> I haven't been capable of building a cordova project for android using the
>> cordova aerogear plugin. First, the plugin is installed like this:
>>
>> cordova plugin add
>> https://github.com/aerogear/aerogear-pushplugin-cordova.git
>>
>> And the plugin is installed succesfully:
>>
>> Fetching plugin
>> "https://github.com/aerogear/aerogear-pushplugin-cordova.git" via git clone
>> Repository "https://github.com/aerogear/aerogear-pushplugin-cordova.git"
>> checked out to git ref "master".
>> Installing "org.jboss.aerogear.cordova.push" for android
>> Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git
>> clone
>> Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to
>> git ref "master".
>>
>> However when building for Android i always get the following errors:
>>
>> FAILURE: Build failed with an exception.
>>
>> * What went wrong:
>> A problem occurred configuring root project 'android'.
>> > Could not resolve all dependencies for configuration ':_debugCompile'.
>>    > Could not find any version that matches
>> com.android.support:appcompat-v7:22.+.
>>      Searched in the following locations:
>>
>> https://repo1.maven.org/maven2/com/android/support/appcompat-v7/maven-metadata.xml
>>          https://repo1.maven.org/maven2/com/android/support/appcompat-v7/
>>      Required by:
>>          :android:unspecified
>>    > Could not find
>> org.jboss.aerogear:aerogear-android-core:2.2.0-SNAPSHOT.
>>      Searched in the following locations:
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-core/2.2.0-SNAPSHOT/maven-metadata.xml
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-core/2.2.0-SNAPSHOT/aerogear-android-core-2.2.0-SNAPSHOT.pom
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-core/2.2.0-SNAPSHOT/aerogear-android-core-2.2.0-SNAPSHOT.jar
>>      Required by:
>>          :android:unspecified
>>    > Could not find
>> org.jboss.aerogear:aerogear-android-pipe:2.2.0-SNAPSHOT.
>>      Searched in the following locations:
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-pipe/2.2.0-SNAPSHOT/maven-metadata.xml
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-pipe/2.2.0-SNAPSHOT/aerogear-android-pipe-2.2.0-SNAPSHOT.pom
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-pipe/2.2.0-SNAPSHOT/aerogear-android-pipe-2.2.0-SNAPSHOT.jar
>>      Required by:
>>          :android:unspecified
>>    > Could not find
>> org.jboss.aerogear:aerogear-android-push:2.2.0-SNAPSHOT.
>>      Searched in the following locations:
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-push/2.2.0-SNAPSHOT/maven-metadata.xml
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-push/2.2.0-SNAPSHOT/aerogear-android-push-2.2.0-SNAPSHOT.pom
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-push/2.2.0-SNAPSHOT/aerogear-android-push-2.2.0-SNAPSHOT.jar
>>      Required by:
>>          :android:unspecified
>>
>> I tried unistalling cordova and npm, but to no avail i haven't been
>> capable of building an app that uses AeroGear.
>>
>> Any assistance is gladly welcome.
>>
>> P.S: Using Cordova 5.1.1 for Android 5.1
>>
>>
>> _______________________________________________
>> Aerogear-users mailing list
>> [hidden email]
>> https://lists.jboss.org/mailman/listinfo/aerogear-users
>>
>> _______________________________________________
>> Aerogear-users mailing list
>> [hidden email]
>> https://lists.jboss.org/mailman/listinfo/aerogear-users
>
>
> _______________________________________________
> Aerogear-users mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/aerogear-users
>



--
Cheers,
       Erik Jan

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Cannot build cordova project with aerogear push plugin

Fabio Turizo
Do you have an estimate when this new version would be released?

El mar., 23 de jun. de 2015 a la(s) 3:15 a. m., Erik Jan de Wit <[hidden email]> escribió:
seems that it can't get one of the plugin dependencies with git
(cordova-plugin-android-support-v4) we depend on this plugin with a
fixed commit because it doesn't have any tags or releases. Now it
seems that the commit we depend on is no longer there. We need to
release another version of the plugin to fix this.

On Mon, Jun 22, 2015 at 3:26 PM, Fabio Turizo <[hidden email]> wrote:
> I tried installing the plugin as you instructed, but i get the following
> error:
>
> WARNING: org.jboss.aerogear.cordova.push has been renamed to
> aerogear-cordova-push. You may not be getting the latest version! We suggest
> you `cordova plugin rm org.jboss.aerogear.cordova.push` and `cordova plugin
> add aerogear-cordova-push`.
> Fetching plugin "org.jboss.aerogear.cordova.push" via cordova plugins
> registry
> npm http GET http://registry.cordova.io/org.jboss.aerogear.cordova.push
> npm http 304 http://registry.cordova.io/org.jboss.aerogear.cordova.push
> Installing "org.jboss.aerogear.cordova.push" for android
> Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git
> clone
> Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to
> git ref "master".
> Installing "com.vladstirbu.cordova.promise" for android
> Fetching plugin
> "https://github.com/MobileChromeApps/cordova-plugin-android-support-v4" via
> git clone
> Failed to install 'org.jboss.aerogear.cordova.push':Error: C:\Program Files
> (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
> Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
> warning: Could not find remote branch
> 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
> fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in
> upstream origin
> Unexpected end of command stream
>     at ChildProcess.whenDone
> (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
>     at ChildProcess.emit (events.js:110:17)
>     at maybeClose (child_process.js:1015:16)
>     at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
> Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit code
> 128 Error output:
> Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
> warning: Could not find remote branch
> 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
> fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found in
> upstream origin
> Unexpected end of command stream
>     at ChildProcess.whenDone
> (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
>     at ChildProcess.emit (events.js:110:17)
>     at maybeClose (child_process.js:1015:16)
>     at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
>
> I'm getting this error in multiple workstations, so i'm assuming the plugin
> installation has issues.
>
> El dom., 21 de jun. de 2015 a la(s) 11:32 p. m., Sébastien Blanc
> <[hidden email]> escribió:
>>
>> Hi !
>> The plugin from GitHub master relies on an aerogear android library with a
>> snapshot version that is not on maven.
>> The easiest way is to install the plugin  from cordova's registry :
>>
>> cordova plugin add org.jboss.aerogear.cordova.push
>>
>> If you really need the master version of the plugi. You will need to build
>> all the android lib locally.
>> Sebi
>>
>>
>> Envoyé de mon iPhone
>>
>> Le 22 juin 2015 à 02:34, Fabio Turizo <[hidden email]> a écrit :
>>
>> I haven't been capable of building a cordova project for android using the
>> cordova aerogear plugin. First, the plugin is installed like this:
>>
>> cordova plugin add
>> https://github.com/aerogear/aerogear-pushplugin-cordova.git
>>
>> And the plugin is installed succesfully:
>>
>> Fetching plugin
>> "https://github.com/aerogear/aerogear-pushplugin-cordova.git" via git clone
>> Repository "https://github.com/aerogear/aerogear-pushplugin-cordova.git"
>> checked out to git ref "master".
>> Installing "org.jboss.aerogear.cordova.push" for android
>> Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git
>> clone
>> Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out to
>> git ref "master".
>>
>> However when building for Android i always get the following errors:
>>
>> FAILURE: Build failed with an exception.
>>
>> * What went wrong:
>> A problem occurred configuring root project 'android'.
>> > Could not resolve all dependencies for configuration ':_debugCompile'.
>>    > Could not find any version that matches
>> com.android.support:appcompat-v7:22.+.
>>      Searched in the following locations:
>>
>> https://repo1.maven.org/maven2/com/android/support/appcompat-v7/maven-metadata.xml
>>          https://repo1.maven.org/maven2/com/android/support/appcompat-v7/
>>      Required by:
>>          :android:unspecified
>>    > Could not find
>> org.jboss.aerogear:aerogear-android-core:2.2.0-SNAPSHOT.
>>      Searched in the following locations:
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-core/2.2.0-SNAPSHOT/maven-metadata.xml
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-core/2.2.0-SNAPSHOT/aerogear-android-core-2.2.0-SNAPSHOT.pom
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-core/2.2.0-SNAPSHOT/aerogear-android-core-2.2.0-SNAPSHOT.jar
>>      Required by:
>>          :android:unspecified
>>    > Could not find
>> org.jboss.aerogear:aerogear-android-pipe:2.2.0-SNAPSHOT.
>>      Searched in the following locations:
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-pipe/2.2.0-SNAPSHOT/maven-metadata.xml
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-pipe/2.2.0-SNAPSHOT/aerogear-android-pipe-2.2.0-SNAPSHOT.pom
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-pipe/2.2.0-SNAPSHOT/aerogear-android-pipe-2.2.0-SNAPSHOT.jar
>>      Required by:
>>          :android:unspecified
>>    > Could not find
>> org.jboss.aerogear:aerogear-android-push:2.2.0-SNAPSHOT.
>>      Searched in the following locations:
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-push/2.2.0-SNAPSHOT/maven-metadata.xml
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-push/2.2.0-SNAPSHOT/aerogear-android-push-2.2.0-SNAPSHOT.pom
>>
>> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-push/2.2.0-SNAPSHOT/aerogear-android-push-2.2.0-SNAPSHOT.jar
>>      Required by:
>>          :android:unspecified
>>
>> I tried unistalling cordova and npm, but to no avail i haven't been
>> capable of building an app that uses AeroGear.
>>
>> Any assistance is gladly welcome.
>>
>> P.S: Using Cordova 5.1.1 for Android 5.1
>>
>>
>> _______________________________________________
>> Aerogear-users mailing list
>> [hidden email]
>> https://lists.jboss.org/mailman/listinfo/aerogear-users
>>
>> _______________________________________________
>> Aerogear-users mailing list
>> [hidden email]
>> https://lists.jboss.org/mailman/listinfo/aerogear-users
>
>
> _______________________________________________
> Aerogear-users mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/aerogear-users
>



--
Cheers,
       Erik Jan

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Cannot build cordova project with aerogear push plugin

Erik Jan de Wit
Yeah tomorrow

On Tue, Jun 23, 2015 at 4:17 PM, Fabio Turizo <[hidden email]> wrote:

> Do you have an estimate when this new version would be released?
>
> El mar., 23 de jun. de 2015 a la(s) 3:15 a. m., Erik Jan de Wit
> <[hidden email]> escribió:
>>
>> seems that it can't get one of the plugin dependencies with git
>> (cordova-plugin-android-support-v4) we depend on this plugin with a
>> fixed commit because it doesn't have any tags or releases. Now it
>> seems that the commit we depend on is no longer there. We need to
>> release another version of the plugin to fix this.
>>
>> On Mon, Jun 22, 2015 at 3:26 PM, Fabio Turizo <[hidden email]>
>> wrote:
>> > I tried installing the plugin as you instructed, but i get the following
>> > error:
>> >
>> > WARNING: org.jboss.aerogear.cordova.push has been renamed to
>> > aerogear-cordova-push. You may not be getting the latest version! We
>> > suggest
>> > you `cordova plugin rm org.jboss.aerogear.cordova.push` and `cordova
>> > plugin
>> > add aerogear-cordova-push`.
>> > Fetching plugin "org.jboss.aerogear.cordova.push" via cordova plugins
>> > registry
>> > npm http GET http://registry.cordova.io/org.jboss.aerogear.cordova.push
>> > npm http 304 http://registry.cordova.io/org.jboss.aerogear.cordova.push
>> > Installing "org.jboss.aerogear.cordova.push" for android
>> > Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git
>> > clone
>> > Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out
>> > to
>> > git ref "master".
>> > Installing "com.vladstirbu.cordova.promise" for android
>> > Fetching plugin
>> > "https://github.com/MobileChromeApps/cordova-plugin-android-support-v4"
>> > via
>> > git clone
>> > Failed to install 'org.jboss.aerogear.cordova.push':Error: C:\Program
>> > Files
>> > (x86)\Git\cmd\git.exe: Command failed with exit code 128 Error output:
>> > Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
>> > warning: Could not find remote branch
>> > 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
>> > fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found
>> > in
>> > upstream origin
>> > Unexpected end of command stream
>> >     at ChildProcess.whenDone
>> >
>> > (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
>> >     at ChildProcess.emit (events.js:110:17)
>> >     at maybeClose (child_process.js:1015:16)
>> >     at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
>> > Error: C:\Program Files (x86)\Git\cmd\git.exe: Command failed with exit
>> > code
>> > 128 Error output:
>> > Cloning into 'C:\Users\fturizo\AppData\Local\Temp\git\1434978837894'...
>> > warning: Could not find remote branch
>> > 8670959210f07f5a483e40b7fbfdb8ca5a50d3f to clone.
>> > fatal: Remote branch 8670959210f07f5a483e40b7fbfdb8ca5a50d3f not found
>> > in
>> > upstream origin
>> > Unexpected end of command stream
>> >     at ChildProcess.whenDone
>> >
>> > (C:\Users\fturizo\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\superspawn.js:134:23)
>> >     at ChildProcess.emit (events.js:110:17)
>> >     at maybeClose (child_process.js:1015:16)
>> >     at Process.ChildProcess._handle.onexit (child_process.js:1087:5)
>> >
>> > I'm getting this error in multiple workstations, so i'm assuming the
>> > plugin
>> > installation has issues.
>> >
>> > El dom., 21 de jun. de 2015 a la(s) 11:32 p. m., Sébastien Blanc
>> > <[hidden email]> escribió:
>> >>
>> >> Hi !
>> >> The plugin from GitHub master relies on an aerogear android library
>> >> with a
>> >> snapshot version that is not on maven.
>> >> The easiest way is to install the plugin  from cordova's registry :
>> >>
>> >> cordova plugin add org.jboss.aerogear.cordova.push
>> >>
>> >> If you really need the master version of the plugi. You will need to
>> >> build
>> >> all the android lib locally.
>> >> Sebi
>> >>
>> >>
>> >> Envoyé de mon iPhone
>> >>
>> >> Le 22 juin 2015 à 02:34, Fabio Turizo <[hidden email]> a écrit
>> >> :
>> >>
>> >> I haven't been capable of building a cordova project for android using
>> >> the
>> >> cordova aerogear plugin. First, the plugin is installed like this:
>> >>
>> >> cordova plugin add
>> >> https://github.com/aerogear/aerogear-pushplugin-cordova.git
>> >>
>> >> And the plugin is installed succesfully:
>> >>
>> >> Fetching plugin
>> >> "https://github.com/aerogear/aerogear-pushplugin-cordova.git" via git
>> >> clone
>> >> Repository
>> >> "https://github.com/aerogear/aerogear-pushplugin-cordova.git"
>> >> checked out to git ref "master".
>> >> Installing "org.jboss.aerogear.cordova.push" for android
>> >> Fetching plugin "https://github.com/vstirbu/PromisesPlugin.git" via git
>> >> clone
>> >> Repository "https://github.com/vstirbu/PromisesPlugin.git" checked out
>> >> to
>> >> git ref "master".
>> >>
>> >> However when building for Android i always get the following errors:
>> >>
>> >> FAILURE: Build failed with an exception.
>> >>
>> >> * What went wrong:
>> >> A problem occurred configuring root project 'android'.
>> >> > Could not resolve all dependencies for configuration
>> >> > ':_debugCompile'.
>> >>    > Could not find any version that matches
>> >> com.android.support:appcompat-v7:22.+.
>> >>      Searched in the following locations:
>> >>
>> >>
>> >> https://repo1.maven.org/maven2/com/android/support/appcompat-v7/maven-metadata.xml
>> >>
>> >> https://repo1.maven.org/maven2/com/android/support/appcompat-v7/
>> >>      Required by:
>> >>          :android:unspecified
>> >>    > Could not find
>> >> org.jboss.aerogear:aerogear-android-core:2.2.0-SNAPSHOT.
>> >>      Searched in the following locations:
>> >>
>> >>
>> >> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-core/2.2.0-SNAPSHOT/maven-metadata.xml
>> >>
>> >>
>> >> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-core/2.2.0-SNAPSHOT/aerogear-android-core-2.2.0-SNAPSHOT.pom
>> >>
>> >>
>> >> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-core/2.2.0-SNAPSHOT/aerogear-android-core-2.2.0-SNAPSHOT.jar
>> >>      Required by:
>> >>          :android:unspecified
>> >>    > Could not find
>> >> org.jboss.aerogear:aerogear-android-pipe:2.2.0-SNAPSHOT.
>> >>      Searched in the following locations:
>> >>
>> >>
>> >> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-pipe/2.2.0-SNAPSHOT/maven-metadata.xml
>> >>
>> >>
>> >> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-pipe/2.2.0-SNAPSHOT/aerogear-android-pipe-2.2.0-SNAPSHOT.pom
>> >>
>> >>
>> >> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-pipe/2.2.0-SNAPSHOT/aerogear-android-pipe-2.2.0-SNAPSHOT.jar
>> >>      Required by:
>> >>          :android:unspecified
>> >>    > Could not find
>> >> org.jboss.aerogear:aerogear-android-push:2.2.0-SNAPSHOT.
>> >>      Searched in the following locations:
>> >>
>> >>
>> >> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-push/2.2.0-SNAPSHOT/maven-metadata.xml
>> >>
>> >>
>> >> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-push/2.2.0-SNAPSHOT/aerogear-android-push-2.2.0-SNAPSHOT.pom
>> >>
>> >>
>> >> https://repo1.maven.org/maven2/org/jboss/aerogear/aerogear-android-push/2.2.0-SNAPSHOT/aerogear-android-push-2.2.0-SNAPSHOT.jar
>> >>      Required by:
>> >>          :android:unspecified
>> >>
>> >> I tried unistalling cordova and npm, but to no avail i haven't been
>> >> capable of building an app that uses AeroGear.
>> >>
>> >> Any assistance is gladly welcome.
>> >>
>> >> P.S: Using Cordova 5.1.1 for Android 5.1
>> >>
>> >>
>> >> _______________________________________________
>> >> Aerogear-users mailing list
>> >> [hidden email]
>> >> https://lists.jboss.org/mailman/listinfo/aerogear-users
>> >>
>> >> _______________________________________________
>> >> Aerogear-users mailing list
>> >> [hidden email]
>> >> https://lists.jboss.org/mailman/listinfo/aerogear-users
>> >
>> >
>> > _______________________________________________
>> > Aerogear-users mailing list
>> > [hidden email]
>> > https://lists.jboss.org/mailman/listinfo/aerogear-users
>> >
>>
>>
>>
>> --
>> Cheers,
>>        Erik Jan
>>
>> _______________________________________________
>> Aerogear-users mailing list
>> [hidden email]
>> https://lists.jboss.org/mailman/listinfo/aerogear-users
>
>
> _______________________________________________
> Aerogear-users mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/aerogear-users
>



--
Cheers,
       Erik Jan

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Loading...