Quantcast

[Aerogear-users] Compile with latest Cocoapods

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Aerogear-users] Compile with latest Cocoapods

Nataniel Martin
Hi !

I would like to know if you updated the cocoapod for your latest release of aerogear-ios-sync-client ?

There’s no way I can compile, I still have error like these:


So this is related with another pod but still I think the project aerogear-ios-sync-client is not correctly updated

Best regards,

Nataniel.

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Compile with latest Cocoapods

Corinne Krych
Hello Nataniel,

By the look of the errors it seems the Swift syntax of starscream is not using Swift 2. This is hinted by the error on 'join' (Swift1.0 syntax) whereas joinWithSeparator() is Swift 2 syntax).
In Podfile[1] check you're pointing to starscream 1.0.2+ or latest version on master. Previous version of the lib used Swift 1 syntax.

++
Corinne


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Compile with latest Cocoapods

Nataniel Martin
Hi,
Thanks for your response.

It’s still not working with this configuration:

PODFILE:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!

pod 'AeroGearSyncClient'
pod 'Starscream', '~> 1.0’


POD INSTALL:

CocoaPods 1.0.0.beta.2 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `Starscream (~> 1.0)` required by `Podfile`
- `Starscream (= 0.9.3)` required by `Podfile.lock`

Specs satisfying the `Starscream (= 0.9.3)` dependency were found, but they required a higher minimum deployment target.

On 07 Jan 2016, at 17:34, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

By the look of the errors it seems the Swift syntax of starscream is not using Swift 2. This is hinted by the error on 'join' (Swift1.0 syntax) whereas joinWithSeparator() is Swift 2 syntax).
In Podfile[1] check you're pointing to starscream 1.0.2+ or latest version on master. Previous version of the lib used Swift 1 syntax.

++
Corinne

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Compile with latest Cocoapods

Corinne Krych
Hi 

Looking into aerogear-ios-sync-client release it seems 1.0.0-alpha.3 (which update to Swift 2 syntax) did not make it to cocoapods although we did have a tag for it [1].
1.0.0-alpha.2 (the latest on cocoapods is still on Swift 1.2 syntax).
I'm going to release 1.0.0-alpha.3 shortly in the meantime (as a work around), please us the latest git master version as shown [2].

++
Corinne

On 8 January 2016 at 08:39, Nataniel Martin <[hidden email]> wrote:
Hi,
Thanks for your response.

It’s still not working with this configuration:

PODFILE:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!

pod 'AeroGearSyncClient'
pod 'Starscream', '~> 1.0’


POD INSTALL:

CocoaPods 1.0.0.beta.2 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `Starscream (~> 1.0)` required by `Podfile`
- `Starscream (= 0.9.3)` required by `Podfile.lock`

Specs satisfying the `Starscream (= 0.9.3)` dependency were found, but they required a higher minimum deployment target.

On 07 Jan 2016, at 17:34, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

By the look of the errors it seems the Swift syntax of starscream is not using Swift 2. This is hinted by the error on 'join' (Swift1.0 syntax) whereas joinWithSeparator() is Swift 2 syntax).
In Podfile[1] check you're pointing to starscream 1.0.2+ or latest version on master. Previous version of the lib used Swift 1 syntax.

++
Corinne

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users



_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Compile with latest Cocoapods

Nataniel Martin
Hi,

Thanks for the swift reply :)

Looking forward for the new version !

But using the exemple in [2] such as:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!


Still give me some errors like these:

Analyzing dependencies
Pre-downloading: `AeroGearSyncClient` from `<a href="https://github.com/aerogear/aerogear-ios-sync-client`" class="">https://github.com/aerogear/aerogear-ios-sync-client`
[!] Unable to find a specification for 'AeroGearSyncClient'.

I think the problem is related when you lint the pod.

Best regards ! 

On 08 Jan 2016, at 12:01, Corinne Krych <[hidden email]> wrote:

Hi 

Looking into aerogear-ios-sync-client release it seems 1.0.0-alpha.3 (which update to Swift 2 syntax) did not make it to cocoapods although we did have a tag for it [1].
1.0.0-alpha.2 (the latest on cocoapods is still on Swift 1.2 syntax).
I'm going to release 1.0.0-alpha.3 shortly in the meantime (as a work around), please us the latest git master version as shown [2].

++
Corinne

On 8 January 2016 at 08:39, Nataniel Martin <[hidden email]> wrote:
Hi,
Thanks for your response.

It’s still not working with this configuration:

PODFILE:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!

pod 'AeroGearSyncClient'
pod 'Starscream', '~> 1.0’


POD INSTALL:

CocoaPods 1.0.0.beta.2 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `Starscream (~> 1.0)` required by `Podfile`
- `Starscream (= 0.9.3)` required by `Podfile.lock`

Specs satisfying the `Starscream (= 0.9.3)` dependency were found, but they required a higher minimum deployment target.

On 07 Jan 2016, at 17:34, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

By the look of the errors it seems the Swift syntax of starscream is not using Swift 2. This is hinted by the error on 'join' (Swift1.0 syntax) whereas joinWithSeparator() is Swift 2 syntax).
In Podfile[1] check you're pointing to starscream 1.0.2+ or latest version on master. Previous version of the lib used Swift 1 syntax.

++
Corinne

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Compile with latest Cocoapods

Corinne Krych
Which cocoapods version are you on?
++
Corinne

On 8 January 2016 at 09:08, Nataniel Martin <[hidden email]> wrote:
Hi,

Thanks for the swift reply :)

Looking forward for the new version !

But using the exemple in [2] such as:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!


Still give me some errors like these:

Analyzing dependencies
Pre-downloading: `AeroGearSyncClient` from `https://github.com/aerogear/aerogear-ios-sync-client`
[!] Unable to find a specification for 'AeroGearSyncClient'.

I think the problem is related when you lint the pod.

Best regards ! 

On 08 Jan 2016, at 12:01, Corinne Krych <[hidden email]> wrote:

Hi 

Looking into aerogear-ios-sync-client release it seems 1.0.0-alpha.3 (which update to Swift 2 syntax) did not make it to cocoapods although we did have a tag for it [1].
1.0.0-alpha.2 (the latest on cocoapods is still on Swift 1.2 syntax).
I'm going to release 1.0.0-alpha.3 shortly in the meantime (as a work around), please us the latest git master version as shown [2].

++
Corinne

On 8 January 2016 at 08:39, Nataniel Martin <[hidden email]> wrote:
Hi,
Thanks for your response.

It’s still not working with this configuration:

PODFILE:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!

pod 'AeroGearSyncClient'
pod 'Starscream', '~> 1.0’


POD INSTALL:

CocoaPods 1.0.0.beta.2 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `Starscream (~> 1.0)` required by `Podfile`
- `Starscream (= 0.9.3)` required by `Podfile.lock`

Specs satisfying the `Starscream (= 0.9.3)` dependency were found, but they required a higher minimum deployment target.

On 07 Jan 2016, at 17:34, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

By the look of the errors it seems the Swift syntax of starscream is not using Swift 2. This is hinted by the error on 'join' (Swift1.0 syntax) whereas joinWithSeparator() is Swift 2 syntax).
In Podfile[1] check you're pointing to starscream 1.0.2+ or latest version on master. Previous version of the lib used Swift 1 syntax.

++
Corinne

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users



_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Compile with latest Cocoapods

Nataniel Martin
The cocoa pod version is: 
0.39.0

It’s the latest, not the last beta version that is 1.0.0.beta.2

Regards,
Nataniel

On 08 Jan 2016, at 12:10, Corinne Krych <[hidden email]> wrote:

Which cocoapods version are you on?
++
Corinne

On 8 January 2016 at 09:08, Nataniel Martin <[hidden email]> wrote:
Hi,

Thanks for the swift reply :)

Looking forward for the new version !

But using the exemple in [2] such as:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!


Still give me some errors like these:

Analyzing dependencies
Pre-downloading: `AeroGearSyncClient` from `https://github.com/aerogear/aerogear-ios-sync-client`
[!] Unable to find a specification for 'AeroGearSyncClient'.

I think the problem is related when you lint the pod.

Best regards ! 

On 08 Jan 2016, at 12:01, Corinne Krych <[hidden email]> wrote:

Hi 

Looking into aerogear-ios-sync-client release it seems 1.0.0-alpha.3 (which update to Swift 2 syntax) did not make it to cocoapods although we did have a tag for it [1].
1.0.0-alpha.2 (the latest on cocoapods is still on Swift 1.2 syntax).
I'm going to release 1.0.0-alpha.3 shortly in the meantime (as a work around), please us the latest git master version as shown [2].

++
Corinne

On 8 January 2016 at 08:39, Nataniel Martin <[hidden email]> wrote:
Hi,
Thanks for your response.

It’s still not working with this configuration:

PODFILE:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!

pod 'AeroGearSyncClient'
pod 'Starscream', '~> 1.0’


POD INSTALL:

CocoaPods 1.0.0.beta.2 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `Starscream (~> 1.0)` required by `Podfile`
- `Starscream (= 0.9.3)` required by `Podfile.lock`

Specs satisfying the `Starscream (= 0.9.3)` dependency were found, but they required a higher minimum deployment target.

On 07 Jan 2016, at 17:34, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

By the look of the errors it seems the Swift syntax of starscream is not using Swift 2. This is hinted by the error on 'join' (Swift1.0 syntax) whereas joinWithSeparator() is Swift 2 syntax).
In Podfile[1] check you're pointing to starscream 1.0.2+ or latest version on master. Previous version of the lib used Swift 1 syntax.

++
Corinne

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Compile with latest Cocoapods

Corinne Krych
Hi Nataniel

Sorry my bad the pod on master are expressed slightly different (no subpod anymore) see correct syntax [1]. Replace AeroGearSyncClient by  AeroGearSyncClientJsonPatch. 
This is a workaround until i do proper release.
++
Corinne

On 8 January 2016 at 09:15, Nataniel Martin <[hidden email]> wrote:
The cocoa pod version is: 
0.39.0

It’s the latest, not the last beta version that is 1.0.0.beta.2

Regards,
Nataniel

On 08 Jan 2016, at 12:10, Corinne Krych <[hidden email]> wrote:

Which cocoapods version are you on?
++
Corinne

On 8 January 2016 at 09:08, Nataniel Martin <[hidden email]> wrote:
Hi,

Thanks for the swift reply :)

Looking forward for the new version !

But using the exemple in [2] such as:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!


Still give me some errors like these:

Analyzing dependencies
Pre-downloading: `AeroGearSyncClient` from `https://github.com/aerogear/aerogear-ios-sync-client`
[!] Unable to find a specification for 'AeroGearSyncClient'.

I think the problem is related when you lint the pod.

Best regards ! 

On 08 Jan 2016, at 12:01, Corinne Krych <[hidden email]> wrote:

Hi 

Looking into aerogear-ios-sync-client release it seems 1.0.0-alpha.3 (which update to Swift 2 syntax) did not make it to cocoapods although we did have a tag for it [1].
1.0.0-alpha.2 (the latest on cocoapods is still on Swift 1.2 syntax).
I'm going to release 1.0.0-alpha.3 shortly in the meantime (as a work around), please us the latest git master version as shown [2].

++
Corinne

On 8 January 2016 at 08:39, Nataniel Martin <[hidden email]> wrote:
Hi,
Thanks for your response.

It’s still not working with this configuration:

PODFILE:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!

pod 'AeroGearSyncClient'
pod 'Starscream', '~> 1.0’


POD INSTALL:

CocoaPods 1.0.0.beta.2 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `Starscream (~> 1.0)` required by `Podfile`
- `Starscream (= 0.9.3)` required by `Podfile.lock`

Specs satisfying the `Starscream (= 0.9.3)` dependency were found, but they required a higher minimum deployment target.

On 07 Jan 2016, at 17:34, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

By the look of the errors it seems the Swift syntax of starscream is not using Swift 2. This is hinted by the error on 'join' (Swift1.0 syntax) whereas joinWithSeparator() is Swift 2 syntax).
In Podfile[1] check you're pointing to starscream 1.0.2+ or latest version on master. Previous version of the lib used Swift 1 syntax.

++
Corinne

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users



_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Compile with latest Cocoapods

Nataniel Martin
Hi,

It’s seems to be better that way !

It would like to point you out that with this workaround, even with the Jedi Demo project, there are two errors while building the project:


It seems that the import of JSONTools file is not correctly bridged for AeroGearSyncJsonPatch.

Best regards,

Nataniel 

On 08 Jan 2016, at 12:44, Corinne Krych <[hidden email]> wrote:

Hi Nataniel

Sorry my bad the pod on master are expressed slightly different (no subpod anymore) see correct syntax [1]. Replace AeroGearSyncClient by  AeroGearSyncClientJsonPatch. 
This is a workaround until i do proper release.
++
Corinne

On 8 January 2016 at 09:15, Nataniel Martin <[hidden email]> wrote:
The cocoa pod version is: 
0.39.0

It’s the latest, not the last beta version that is 1.0.0.beta.2

Regards,
Nataniel

On 08 Jan 2016, at 12:10, Corinne Krych <[hidden email]> wrote:

Which cocoapods version are you on?
++
Corinne

On 8 January 2016 at 09:08, Nataniel Martin <[hidden email]> wrote:
Hi,

Thanks for the swift reply :)

Looking forward for the new version !

But using the exemple in [2] such as:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!


Still give me some errors like these:

Analyzing dependencies
Pre-downloading: `AeroGearSyncClient` from `https://github.com/aerogear/aerogear-ios-sync-client`
[!] Unable to find a specification for 'AeroGearSyncClient'.

I think the problem is related when you lint the pod.

Best regards ! 

On 08 Jan 2016, at 12:01, Corinne Krych <[hidden email]> wrote:

Hi 

Looking into aerogear-ios-sync-client release it seems 1.0.0-alpha.3 (which update to Swift 2 syntax) did not make it to cocoapods although we did have a tag for it [1].
1.0.0-alpha.2 (the latest on cocoapods is still on Swift 1.2 syntax).
I'm going to release 1.0.0-alpha.3 shortly in the meantime (as a work around), please us the latest git master version as shown [2].

++
Corinne

On 8 January 2016 at 08:39, Nataniel Martin <[hidden email]> wrote:
Hi,
Thanks for your response.

It’s still not working with this configuration:

PODFILE:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!

pod 'AeroGearSyncClient'
pod 'Starscream', '~> 1.0’


POD INSTALL:

CocoaPods 1.0.0.beta.2 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `Starscream (~> 1.0)` required by `Podfile`
- `Starscream (= 0.9.3)` required by `Podfile.lock`

Specs satisfying the `Starscream (= 0.9.3)` dependency were found, but they required a higher minimum deployment target.

On 07 Jan 2016, at 17:34, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

By the look of the errors it seems the Swift syntax of starscream is not using Swift 2. This is hinted by the error on 'join' (Swift1.0 syntax) whereas joinWithSeparator() is Swift 2 syntax).
In Podfile[1] check you're pointing to starscream 1.0.2+ or latest version on master. Previous version of the lib used Swift 1 syntax.

++
Corinne

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Compile with latest Cocoapods

Nataniel Martin
Hi !

Any news on these errors ?

I tried a few things on it, but I can’t make it compile :(

Looking forward reading to reading from you.

Nataniel.

On 08 Jan 2016, at 15:02, Nataniel Martin <[hidden email]> wrote:

Hi,

It’s seems to be better that way !

It would like to point you out that with this workaround, even with the Jedi Demo project, there are two errors while building the project:

<Screen Shot 2016-01-08 at 14.52.05.png>

It seems that the import of JSONTools file is not correctly bridged for AeroGearSyncJsonPatch.

Best regards,

Nataniel 

On 08 Jan 2016, at 12:44, Corinne Krych <[hidden email]> wrote:

Hi Nataniel

Sorry my bad the pod on master are expressed slightly different (no subpod anymore) see correct syntax [1]. Replace AeroGearSyncClient by  AeroGearSyncClientJsonPatch. 
This is a workaround until i do proper release.
++
Corinne

On 8 January 2016 at 09:15, Nataniel Martin <[hidden email]> wrote:
The cocoa pod version is: 
0.39.0

It’s the latest, not the last beta version that is 1.0.0.beta.2

Regards,
Nataniel

On 08 Jan 2016, at 12:10, Corinne Krych <[hidden email]> wrote:

Which cocoapods version are you on?
++
Corinne

On 8 January 2016 at 09:08, Nataniel Martin <[hidden email]> wrote:
Hi,

Thanks for the swift reply :)

Looking forward for the new version !

But using the exemple in [2] such as:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!


Still give me some errors like these:

Analyzing dependencies
Pre-downloading: `AeroGearSyncClient` from `https://github.com/aerogear/aerogear-ios-sync-client`
[!] Unable to find a specification for 'AeroGearSyncClient'.

I think the problem is related when you lint the pod.

Best regards ! 

On 08 Jan 2016, at 12:01, Corinne Krych <[hidden email]> wrote:

Hi 

Looking into aerogear-ios-sync-client release it seems 1.0.0-alpha.3 (which update to Swift 2 syntax) did not make it to cocoapods although we did have a tag for it [1].
1.0.0-alpha.2 (the latest on cocoapods is still on Swift 1.2 syntax).
I'm going to release 1.0.0-alpha.3 shortly in the meantime (as a work around), please us the latest git master version as shown [2].

++
Corinne

On 8 January 2016 at 08:39, Nataniel Martin <[hidden email]> wrote:
Hi,
Thanks for your response.

It’s still not working with this configuration:

PODFILE:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!

pod 'AeroGearSyncClient'
pod 'Starscream', '~> 1.0’


POD INSTALL:

CocoaPods 1.0.0.beta.2 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `Starscream (~> 1.0)` required by `Podfile`
- `Starscream (= 0.9.3)` required by `Podfile.lock`

Specs satisfying the `Starscream (= 0.9.3)` dependency were found, but they required a higher minimum deployment target.

On 07 Jan 2016, at 17:34, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

By the look of the errors it seems the Swift syntax of starscream is not using Swift 2. This is hinted by the error on 'join' (Swift1.0 syntax) whereas joinWithSeparator() is Swift 2 syntax).
In Podfile[1] check you're pointing to starscream 1.0.2+ or latest version on master. Previous version of the lib used Swift 1 syntax.

++
Corinne

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users



_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Compile with latest Cocoapods

Nataniel Martin
By the way Corrinne,

What version of Xcode / SWIFT are you using ?

FYI I’m using Xcode 7.2 + Swift 2.1.

Seems that flags are not correctly set.

Best regards,

Nataniel

On 11 Jan 2016, at 11:54, Nataniel Martin <[hidden email]> wrote:

Hi !

Any news on these errors ?

I tried a few things on it, but I can’t make it compile :(

Looking forward reading to reading from you.

Nataniel.

On 08 Jan 2016, at 15:02, Nataniel Martin <[hidden email]> wrote:

Hi,

It’s seems to be better that way !

It would like to point you out that with this workaround, even with the Jedi Demo project, there are two errors while building the project:

<Screen Shot 2016-01-08 at 14.52.05.png>

It seems that the import of JSONTools file is not correctly bridged for AeroGearSyncJsonPatch.

Best regards,

Nataniel 

On 08 Jan 2016, at 12:44, Corinne Krych <[hidden email]> wrote:

Hi Nataniel

Sorry my bad the pod on master are expressed slightly different (no subpod anymore) see correct syntax [1]. Replace AeroGearSyncClient by  AeroGearSyncClientJsonPatch. 
This is a workaround until i do proper release.
++
Corinne

On 8 January 2016 at 09:15, Nataniel Martin <[hidden email]> wrote:
The cocoa pod version is: 
0.39.0

It’s the latest, not the last beta version that is 1.0.0.beta.2

Regards,
Nataniel

On 08 Jan 2016, at 12:10, Corinne Krych <[hidden email]> wrote:

Which cocoapods version are you on?
++
Corinne

On 8 January 2016 at 09:08, Nataniel Martin <[hidden email]> wrote:
Hi,

Thanks for the swift reply :)

Looking forward for the new version !

But using the exemple in [2] such as:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!


Still give me some errors like these:

Analyzing dependencies
Pre-downloading: `AeroGearSyncClient` from `https://github.com/aerogear/aerogear-ios-sync-client`
[!] Unable to find a specification for 'AeroGearSyncClient'.

I think the problem is related when you lint the pod.

Best regards ! 

On 08 Jan 2016, at 12:01, Corinne Krych <[hidden email]> wrote:

Hi 

Looking into aerogear-ios-sync-client release it seems 1.0.0-alpha.3 (which update to Swift 2 syntax) did not make it to cocoapods although we did have a tag for it [1].
1.0.0-alpha.2 (the latest on cocoapods is still on Swift 1.2 syntax).
I'm going to release 1.0.0-alpha.3 shortly in the meantime (as a work around), please us the latest git master version as shown [2].

++
Corinne

On 8 January 2016 at 08:39, Nataniel Martin <[hidden email]> wrote:
Hi,
Thanks for your response.

It’s still not working with this configuration:

PODFILE:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!

pod 'AeroGearSyncClient'
pod 'Starscream', '~> 1.0’


POD INSTALL:

CocoaPods 1.0.0.beta.2 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `Starscream (~> 1.0)` required by `Podfile`
- `Starscream (= 0.9.3)` required by `Podfile.lock`

Specs satisfying the `Starscream (= 0.9.3)` dependency were found, but they required a higher minimum deployment target.

On 07 Jan 2016, at 17:34, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

By the look of the errors it seems the Swift syntax of starscream is not using Swift 2. This is hinted by the error on 'join' (Swift1.0 syntax) whereas joinWithSeparator() is Swift 2 syntax).
In Podfile[1] check you're pointing to starscream 1.0.2+ or latest version on master. Previous version of the lib used Swift 1 syntax.

++
Corinne

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Compile with latest Cocoapods

Corinne Krych
Hello Nataniel,

I use Xcode 7.2, cocoapods 0.39.0 like you and I faced the same issue.

To sort out the issue, I've defined a new podspec for the ObjC dependencies JSONTools and KiteValidator. Mainly, I rework the import statement and define a modulemap for both libraries. 

As we don't directly own the libs I'll issue a PR and start the discussion. Once it's merged we can do a new cocoapods release. In the mean time, you can try it with these fork/branch, in your Podfile, try [1]. Let me know how it goes for you.

++
Corinne.

On 11 January 2016 at 09:42, Nataniel Martin <[hidden email]> wrote:
By the way Corrinne,

What version of Xcode / SWIFT are you using ?

FYI I’m using Xcode 7.2 + Swift 2.1.

Seems that flags are not correctly set.

Best regards,

Nataniel

On 11 Jan 2016, at 11:54, Nataniel Martin <[hidden email]> wrote:

Hi !

Any news on these errors ?

I tried a few things on it, but I can’t make it compile :(

Looking forward reading to reading from you.

Nataniel.

On 08 Jan 2016, at 15:02, Nataniel Martin <[hidden email]> wrote:

Hi,

It’s seems to be better that way !

It would like to point you out that with this workaround, even with the Jedi Demo project, there are two errors while building the project:

<Screen Shot 2016-01-08 at 14.52.05.png>

It seems that the import of JSONTools file is not correctly bridged for AeroGearSyncJsonPatch.

Best regards,

Nataniel 

On 08 Jan 2016, at 12:44, Corinne Krych <[hidden email]> wrote:

Hi Nataniel

Sorry my bad the pod on master are expressed slightly different (no subpod anymore) see correct syntax [1]. Replace AeroGearSyncClient by  AeroGearSyncClientJsonPatch. 
This is a workaround until i do proper release.
++
Corinne

On 8 January 2016 at 09:15, Nataniel Martin <[hidden email]> wrote:
The cocoa pod version is: 
0.39.0

It’s the latest, not the last beta version that is 1.0.0.beta.2

Regards,
Nataniel

On 08 Jan 2016, at 12:10, Corinne Krych <[hidden email]> wrote:

Which cocoapods version are you on?
++
Corinne

On 8 January 2016 at 09:08, Nataniel Martin <[hidden email]> wrote:
Hi,

Thanks for the swift reply :)

Looking forward for the new version !

But using the exemple in [2] such as:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!


Still give me some errors like these:

Analyzing dependencies
Pre-downloading: `AeroGearSyncClient` from `https://github.com/aerogear/aerogear-ios-sync-client`
[!] Unable to find a specification for 'AeroGearSyncClient'.

I think the problem is related when you lint the pod.

Best regards ! 

On 08 Jan 2016, at 12:01, Corinne Krych <[hidden email]> wrote:

Hi 

Looking into aerogear-ios-sync-client release it seems 1.0.0-alpha.3 (which update to Swift 2 syntax) did not make it to cocoapods although we did have a tag for it [1].
1.0.0-alpha.2 (the latest on cocoapods is still on Swift 1.2 syntax).
I'm going to release 1.0.0-alpha.3 shortly in the meantime (as a work around), please us the latest git master version as shown [2].

++
Corinne

On 8 January 2016 at 08:39, Nataniel Martin <[hidden email]> wrote:
Hi,
Thanks for your response.

It’s still not working with this configuration:

PODFILE:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!

pod 'AeroGearSyncClient'
pod 'Starscream', '~> 1.0’


POD INSTALL:

CocoaPods 1.0.0.beta.2 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `Starscream (~> 1.0)` required by `Podfile`
- `Starscream (= 0.9.3)` required by `Podfile.lock`

Specs satisfying the `Starscream (= 0.9.3)` dependency were found, but they required a higher minimum deployment target.

On 07 Jan 2016, at 17:34, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

By the look of the errors it seems the Swift syntax of starscream is not using Swift 2. This is hinted by the error on 'join' (Swift1.0 syntax) whereas joinWithSeparator() is Swift 2 syntax).
In Podfile[1] check you're pointing to starscream 1.0.2+ or latest version on master. Previous version of the lib used Swift 1 syntax.

++
Corinne

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users



_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Compile with latest Cocoapods

Nataniel Martin
Hi Corrinne,

Thanks you very much for your help !

So this is what it came out with my testings:

1) First the Podfile used a private library: for KiteValidator;
So in order to work that out, had to slightly modify the Podfile like this : 
pod 'KiteJSONValidator', :git => 'https://github.com/corinnekrych/KiteJSONValidator.git', :branch => 'podspec.public.header'


2) The import in ViewController.swift from the project : aerogear-ios-cookbook/Jedi/JsonPatchSync 

import AeroGearSync
import AeroGearSyncClient

Had to be changed like this:

import AeroGearSyncJsonPatch
import AeroGearSyncClientJsonPatch

3) Now i’m facing a other problem :

private var syncClient: SyncClient<JsonPatchSynchronizer, InMemoryDataStore<JsonNode, JsonPatchEdit>>

SyncClient type is unrecognised by the Xcode (even after a build clean)

-----

This were i’m blocked. But i feel that we are not that far from the solution :)

Let me know if I did something wrong along my explanation.

Best regards !

Nataniel

On 11 Jan 2016, at 14:28, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

I use Xcode 7.2, cocoapods 0.39.0 like you and I faced the same issue.

To sort out the issue, I've defined a new podspec for the ObjC dependencies JSONTools and KiteValidator. Mainly, I rework the import statement and define a modulemap for both libraries. 

As we don't directly own the libs I'll issue a PR and start the discussion. Once it's merged we can do a new cocoapods release. In the mean time, you can try it with these fork/branch, in your Podfile, try [1]. Let me know how it goes for you.

++
Corinne.

On 11 January 2016 at 09:42, Nataniel Martin <[hidden email]> wrote:
By the way Corrinne,

What version of Xcode / SWIFT are you using ?

FYI I’m using Xcode 7.2 + Swift 2.1.

Seems that flags are not correctly set.

Best regards,

Nataniel

On 11 Jan 2016, at 11:54, Nataniel Martin <[hidden email]> wrote:

Hi !

Any news on these errors ?

I tried a few things on it, but I can’t make it compile :(

Looking forward reading to reading from you.

Nataniel.

On 08 Jan 2016, at 15:02, Nataniel Martin <[hidden email]> wrote:

Hi,

It’s seems to be better that way !

It would like to point you out that with this workaround, even with the Jedi Demo project, there are two errors while building the project:

<Screen Shot 2016-01-08 at 14.52.05.png>

It seems that the import of JSONTools file is not correctly bridged for AeroGearSyncJsonPatch.

Best regards,

Nataniel 

On 08 Jan 2016, at 12:44, Corinne Krych <[hidden email]> wrote:

Hi Nataniel

Sorry my bad the pod on master are expressed slightly different (no subpod anymore) see correct syntax [1]. Replace AeroGearSyncClient by  AeroGearSyncClientJsonPatch. 
This is a workaround until i do proper release.
++
Corinne

On 8 January 2016 at 09:15, Nataniel Martin <[hidden email]> wrote:
The cocoa pod version is: 
0.39.0

It’s the latest, not the last beta version that is 1.0.0.beta.2

Regards,
Nataniel

On 08 Jan 2016, at 12:10, Corinne Krych <[hidden email]> wrote:

Which cocoapods version are you on?
++
Corinne

On 8 January 2016 at 09:08, Nataniel Martin <[hidden email]> wrote:
Hi,

Thanks for the swift reply :)

Looking forward for the new version !

But using the exemple in [2] such as:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!


Still give me some errors like these:

Analyzing dependencies
Pre-downloading: `AeroGearSyncClient` from `https://github.com/aerogear/aerogear-ios-sync-client`
[!] Unable to find a specification for 'AeroGearSyncClient'.

I think the problem is related when you lint the pod.

Best regards ! 

On 08 Jan 2016, at 12:01, Corinne Krych <[hidden email]> wrote:

Hi 

Looking into aerogear-ios-sync-client release it seems 1.0.0-alpha.3 (which update to Swift 2 syntax) did not make it to cocoapods although we did have a tag for it [1].
1.0.0-alpha.2 (the latest on cocoapods is still on Swift 1.2 syntax).
I'm going to release 1.0.0-alpha.3 shortly in the meantime (as a work around), please us the latest git master version as shown [2].

++
Corinne

On 8 January 2016 at 08:39, Nataniel Martin <[hidden email]> wrote:
Hi,
Thanks for your response.

It’s still not working with this configuration:

PODFILE:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!

pod 'AeroGearSyncClient'
pod 'Starscream', '~> 1.0’


POD INSTALL:

CocoaPods 1.0.0.beta.2 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `Starscream (~> 1.0)` required by `Podfile`
- `Starscream (= 0.9.3)` required by `Podfile.lock`

Specs satisfying the `Starscream (= 0.9.3)` dependency were found, but they required a higher minimum deployment target.

On 07 Jan 2016, at 17:34, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

By the look of the errors it seems the Swift syntax of starscream is not using Swift 2. This is hinted by the error on 'join' (Swift1.0 syntax) whereas joinWithSeparator() is Swift 2 syntax).
In Podfile[1] check you're pointing to starscream 1.0.2+ or latest version on master. Previous version of the lib used Swift 1 syntax.

++
Corinne

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Compile with latest Cocoapods

Corinne Krych
Hi Nataniel

I did the same steps you described to solve the last issue, go to AeroGeatSyncDemo target, select build settings and set:
ONLY_ACTIVE_ARCH = YES;
Then delete do a clean build (delete DerivedData)

Let me know how it goes for you. I'll issue a PR on Jedi cookbook.

++
Corinne

On 11 January 2016 at 12:51, Nataniel Martin <[hidden email]> wrote:
Hi Corrinne,

Thanks you very much for your help !

So this is what it came out with my testings:

1) First the Podfile used a private library: for KiteValidator;
So in order to work that out, had to slightly modify the Podfile like this : 
pod 'KiteJSONValidator', :git => 'https://github.com/corinnekrych/KiteJSONValidator.git', :branch => 'podspec.public.header'


2) The import in ViewController.swift from the project : aerogear-ios-cookbook/Jedi/JsonPatchSync 

import AeroGearSync
import AeroGearSyncClient

Had to be changed like this:

import AeroGearSyncJsonPatch
import AeroGearSyncClientJsonPatch

3) Now i’m facing a other problem :

private var syncClient: SyncClient<JsonPatchSynchronizer, InMemoryDataStore<JsonNode, JsonPatchEdit>>

SyncClient type is unrecognised by the Xcode (even after a build clean)

-----

This were i’m blocked. But i feel that we are not that far from the solution :)

Let me know if I did something wrong along my explanation.

Best regards !

Nataniel

On 11 Jan 2016, at 14:28, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

I use Xcode 7.2, cocoapods 0.39.0 like you and I faced the same issue.

To sort out the issue, I've defined a new podspec for the ObjC dependencies JSONTools and KiteValidator. Mainly, I rework the import statement and define a modulemap for both libraries. 

As we don't directly own the libs I'll issue a PR and start the discussion. Once it's merged we can do a new cocoapods release. In the mean time, you can try it with these fork/branch, in your Podfile, try [1]. Let me know how it goes for you.

++
Corinne.

On 11 January 2016 at 09:42, Nataniel Martin <[hidden email]> wrote:
By the way Corrinne,

What version of Xcode / SWIFT are you using ?

FYI I’m using Xcode 7.2 + Swift 2.1.

Seems that flags are not correctly set.

Best regards,

Nataniel

On 11 Jan 2016, at 11:54, Nataniel Martin <[hidden email]> wrote:

Hi !

Any news on these errors ?

I tried a few things on it, but I can’t make it compile :(

Looking forward reading to reading from you.

Nataniel.

On 08 Jan 2016, at 15:02, Nataniel Martin <[hidden email]> wrote:

Hi,

It’s seems to be better that way !

It would like to point you out that with this workaround, even with the Jedi Demo project, there are two errors while building the project:

<Screen Shot 2016-01-08 at 14.52.05.png>

It seems that the import of JSONTools file is not correctly bridged for AeroGearSyncJsonPatch.

Best regards,

Nataniel 

On 08 Jan 2016, at 12:44, Corinne Krych <[hidden email]> wrote:

Hi Nataniel

Sorry my bad the pod on master are expressed slightly different (no subpod anymore) see correct syntax [1]. Replace AeroGearSyncClient by  AeroGearSyncClientJsonPatch. 
This is a workaround until i do proper release.
++
Corinne

On 8 January 2016 at 09:15, Nataniel Martin <[hidden email]> wrote:
The cocoa pod version is: 
0.39.0

It’s the latest, not the last beta version that is 1.0.0.beta.2

Regards,
Nataniel

On 08 Jan 2016, at 12:10, Corinne Krych <[hidden email]> wrote:

Which cocoapods version are you on?
++
Corinne

On 8 January 2016 at 09:08, Nataniel Martin <[hidden email]> wrote:
Hi,

Thanks for the swift reply :)

Looking forward for the new version !

But using the exemple in [2] such as:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!


Still give me some errors like these:

Analyzing dependencies
Pre-downloading: `AeroGearSyncClient` from `https://github.com/aerogear/aerogear-ios-sync-client`
[!] Unable to find a specification for 'AeroGearSyncClient'.

I think the problem is related when you lint the pod.

Best regards ! 

On 08 Jan 2016, at 12:01, Corinne Krych <[hidden email]> wrote:

Hi 

Looking into aerogear-ios-sync-client release it seems 1.0.0-alpha.3 (which update to Swift 2 syntax) did not make it to cocoapods although we did have a tag for it [1].
1.0.0-alpha.2 (the latest on cocoapods is still on Swift 1.2 syntax).
I'm going to release 1.0.0-alpha.3 shortly in the meantime (as a work around), please us the latest git master version as shown [2].

++
Corinne

On 8 January 2016 at 08:39, Nataniel Martin <[hidden email]> wrote:
Hi,
Thanks for your response.

It’s still not working with this configuration:

PODFILE:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!

pod 'AeroGearSyncClient'
pod 'Starscream', '~> 1.0’


POD INSTALL:

CocoaPods 1.0.0.beta.2 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `Starscream (~> 1.0)` required by `Podfile`
- `Starscream (= 0.9.3)` required by `Podfile.lock`

Specs satisfying the `Starscream (= 0.9.3)` dependency were found, but they required a higher minimum deployment target.

On 07 Jan 2016, at 17:34, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

By the look of the errors it seems the Swift syntax of starscream is not using Swift 2. This is hinted by the error on 'join' (Swift1.0 syntax) whereas joinWithSeparator() is Swift 2 syntax).
In Podfile[1] check you're pointing to starscream 1.0.2+ or latest version on master. Previous version of the lib used Swift 1 syntax.

++
Corinne

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users



_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] Compile with latest Cocoapods

Nataniel Martin
Hi !

That did the trick:

- Alright after cleaning the derivedData folder
- Clean Build Folder
- Clean
- Modified ONLY_ACTIVE_ARCH to yes
- Make sur that i changed the imports in ViewController.swift:

import AeroGearSyncClientJsonPatch
import AeroGearSyncJsonPatch

—— 

It compiled and started the app on simulator.

Thanks for the help !

I will work with that for now.

Looking forward the next update on cocoapods ;)

Till then, thanks and have good day ! 

On 11 Jan 2016, at 16:40, Corinne Krych <[hidden email]> wrote:

Hi Nataniel

I did the same steps you described to solve the last issue, go to AeroGeatSyncDemo target, select build settings and set:
ONLY_ACTIVE_ARCH = YES;
Then delete do a clean build (delete DerivedData)

Let me know how it goes for you. I'll issue a PR on Jedi cookbook.

++
Corinne

On 11 January 2016 at 12:51, Nataniel Martin <[hidden email]> wrote:
Hi Corrinne,

Thanks you very much for your help !

So this is what it came out with my testings:

1) First the Podfile used a private library: for KiteValidator;
So in order to work that out, had to slightly modify the Podfile like this : 
pod 'KiteJSONValidator', :git => 'https://github.com/corinnekrych/KiteJSONValidator.git', :branch => 'podspec.public.header'


2) The import in ViewController.swift from the project : aerogear-ios-cookbook/Jedi/JsonPatchSync 

import AeroGearSync
import AeroGearSyncClient

Had to be changed like this:

import AeroGearSyncJsonPatch
import AeroGearSyncClientJsonPatch

3) Now i’m facing a other problem :

private var syncClient: SyncClient<JsonPatchSynchronizer, InMemoryDataStore<JsonNode, JsonPatchEdit>>

SyncClient type is unrecognised by the Xcode (even after a build clean)

-----

This were i’m blocked. But i feel that we are not that far from the solution :)

Let me know if I did something wrong along my explanation.

Best regards !

Nataniel

On 11 Jan 2016, at 14:28, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

I use Xcode 7.2, cocoapods 0.39.0 like you and I faced the same issue.

To sort out the issue, I've defined a new podspec for the ObjC dependencies JSONTools and KiteValidator. Mainly, I rework the import statement and define a modulemap for both libraries. 

As we don't directly own the libs I'll issue a PR and start the discussion. Once it's merged we can do a new cocoapods release. In the mean time, you can try it with these fork/branch, in your Podfile, try [1]. Let me know how it goes for you.

++
Corinne.

On 11 January 2016 at 09:42, Nataniel Martin <[hidden email]> wrote:
By the way Corrinne,

What version of Xcode / SWIFT are you using ?

FYI I’m using Xcode 7.2 + Swift 2.1.

Seems that flags are not correctly set.

Best regards,

Nataniel

On 11 Jan 2016, at 11:54, Nataniel Martin <[hidden email]> wrote:

Hi !

Any news on these errors ?

I tried a few things on it, but I can’t make it compile :(

Looking forward reading to reading from you.

Nataniel.

On 08 Jan 2016, at 15:02, Nataniel Martin <[hidden email]> wrote:

Hi,

It’s seems to be better that way !

It would like to point you out that with this workaround, even with the Jedi Demo project, there are two errors while building the project:

<Screen Shot 2016-01-08 at 14.52.05.png>

It seems that the import of JSONTools file is not correctly bridged for AeroGearSyncJsonPatch.

Best regards,

Nataniel 

On 08 Jan 2016, at 12:44, Corinne Krych <[hidden email]> wrote:

Hi Nataniel

Sorry my bad the pod on master are expressed slightly different (no subpod anymore) see correct syntax [1]. Replace AeroGearSyncClient by  AeroGearSyncClientJsonPatch. 
This is a workaround until i do proper release.
++
Corinne

On 8 January 2016 at 09:15, Nataniel Martin <[hidden email]> wrote:
The cocoa pod version is: 
0.39.0

It’s the latest, not the last beta version that is 1.0.0.beta.2

Regards,
Nataniel

On 08 Jan 2016, at 12:10, Corinne Krych <[hidden email]> wrote:

Which cocoapods version are you on?
++
Corinne

On 8 January 2016 at 09:08, Nataniel Martin <[hidden email]> wrote:
Hi,

Thanks for the swift reply :)

Looking forward for the new version !

But using the exemple in [2] such as:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!


Still give me some errors like these:

Analyzing dependencies
Pre-downloading: `AeroGearSyncClient` from `https://github.com/aerogear/aerogear-ios-sync-client`
[!] Unable to find a specification for 'AeroGearSyncClient'.

I think the problem is related when you lint the pod.

Best regards ! 

On 08 Jan 2016, at 12:01, Corinne Krych <[hidden email]> wrote:

Hi 

Looking into aerogear-ios-sync-client release it seems 1.0.0-alpha.3 (which update to Swift 2 syntax) did not make it to cocoapods although we did have a tag for it [1].
1.0.0-alpha.2 (the latest on cocoapods is still on Swift 1.2 syntax).
I'm going to release 1.0.0-alpha.3 shortly in the meantime (as a work around), please us the latest git master version as shown [2].

++
Corinne

On 8 January 2016 at 08:39, Nataniel Martin <[hidden email]> wrote:
Hi,
Thanks for your response.

It’s still not working with this configuration:

PODFILE:


platform :ios, '8.0'
platform :ios, :deployment_target => '8.0'
xcodeproj 'TestAerogear.xcodeproj'
use_frameworks!

pod 'AeroGearSyncClient'
pod 'Starscream', '~> 1.0’


POD INSTALL:

CocoaPods 1.0.0.beta.2 is available.
To update use: `gem install cocoapods --pre`
[!] This is a test version we'd love you to try.

For more information see http://blog.cocoapods.org
and the CHANGELOG for this version http://git.io/BaH8pQ.

Analyzing dependencies
[!] Unable to satisfy the following requirements:

- `Starscream (~> 1.0)` required by `Podfile`
- `Starscream (= 0.9.3)` required by `Podfile.lock`

Specs satisfying the `Starscream (= 0.9.3)` dependency were found, but they required a higher minimum deployment target.

On 07 Jan 2016, at 17:34, Corinne Krych <[hidden email]> wrote:

Hello Nataniel,

By the look of the errors it seems the Swift syntax of starscream is not using Swift 2. This is hinted by the error on 'join' (Swift1.0 syntax) whereas joinWithSeparator() is Swift 2 syntax).
In Podfile[1] check you're pointing to starscream 1.0.2+ or latest version on master. Previous version of the lib used Swift 1 syntax.

++
Corinne

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Loading...