[Aerogear-users] Openshift memory and deployment problems

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Aerogear-users] Openshift memory and deployment problems

darekxan
Hello,
We’ve been using aerogear-unified-push on openshift large gear for some time. 

We have two problems, which I cannot find any answers for. I’m in no way experienced on this field

1) Application goes offline once in a while - it appears it uses whole instance’s memory after some time, causing OutOfMemory error. This happens once every 1-2 weeks for us. So, I figured - let’s workaround these memory problems by restarting the app once a while, however:
2) Restarting application doest work. After I run restart from openshift console - cartridge appears to be restarted, wildfly is running, however browsing to /ag-push results in 404 Not Found. I need to manually use rhc-port-forward, then go to wildfly admin console and redeploy artifacts by uploading/enabling them. 
3) This might be related to “control restart” output:

[xxx.rhcloud.com bin]\> ./control restart
Restarting aerogear-push cart
Stopping aerogear-push cart
Sending SIGTERM to wildfly:462504 ...
Starting aerogear-push cart
Found 127.10.62.129:8080 listening port
Found 127.10.62.129:9990 listening port
/var/lib/openshift/xxx/aerogear-push/standalone/deployments /var/lib/openshift/xxx/aerogear-push/bin
/var/lib/openshift/xxx/aerogear-push/bin
CLIENT_MESSAGE: Artifacts in an unknown state: ./auth-server.war ./ag-push.war



Two war files in deployments folder are present, however they are in .undeployed status. Snapshots are not working for us either. The most important thing for us now, is to provide automatic means of restarting the cartridge, which would result in usable application. 

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users