Quantcast

[Aerogear-users] gradle dependency issue with java client

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Aerogear-users] gradle dependency issue with java client

Ronald van Aken
Hi aerogear team,

I am having an issue that my gradle build file cannot find the 1.1.0 library (and dependencies) in the maven repositories as is outlined in the dependency on github. When i try to use the unifiedpush-java-client:1.1.0-alpha.1 i run into several dependency errors in that it cannot find the model and j2ee-jboss libraries. (It puzzles me why the library would require the j2ee libs but that is a different question :)

Do you have any idea how i can best resolve this?

Thanks in advance!
Ronald.

I am using the following repository url's from a gradle script:

  maven {
        url 'https://repository.jboss.org/nexus/content/repositories/'
    }
    maven {
        url 'http://repo1.maven.org/maven/'

    }
    maven {
        url 'http://repo.maven.apache.org/maven2/'
    }

errors i am getting are:

org.jboss.aerogear:unifiedpush-java-client:1.1.0-alpha.1
      > Could not parse POM http://repo1.maven.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-push-model/1.1.0-alpha.1/unifiedpush-push-model-1.1.0-alpha.1.pom
      > Could not resolve org.jboss.aerogear.unifiedpush:unifiedpush-push-parent:1.1.0-alpha.1.
            > Could not parse POM http://repo1.maven.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-push-parent/1.1.0-alpha.1/unifiedpush-push-parent-1.1.0-alpha.1.pom
            > Could not resolve org.jboss.aerogear.unifiedpush:unifiedpush-parent:1.1.0-alpha.1.
                  > Could not parse POM http://repo1.maven.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-parent/1.1.0-alpha.1/unifiedpush-parent-1.1.0-alpha.1.pom
                  > Could not download artifact 'org.jboss.spec:jboss-javaee-6.0:3.0.2.Final:jboss-javaee-6.0.pom'
                     > Could not HEAD 'http://repo.ont.powerhouse.local:18080/content/groups/local/org/jboss/spec/jboss-javaee-6.0/3.0.2.Final/jboss-javaee-6.0-3.0.2.Final.pom'.
                        > repo.ont.powerhouse.local
               > Could not parse POM http://repo.maven.apache.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-parent/1.1.0-alpha.1/unifiedpush-parent-1.1.0-alpha.1.pom
                  > Could not download artifact 'org.jboss.spec:jboss-javaee-6.0:3.0.2.Final:jboss-javaee-6.0.pom'
               > Could not parse POM http://repo1.maven.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-parent/1.1.0-alpha.1/unifiedpush-parent-1.1.0-alpha.1.pom
                  > Could not download artifact 'org.jboss.spec:jboss-javaee-6.0:3.0.2.Final:jboss-javaee-6.0.pom'
               > Could not parse POM http://repo.maven.apache.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-parent/1.1.0-alpha.1/unifiedpush-parent-1.1.0-alpha.1.pom
                  > Could not download artifact 'org.jboss.spec:jboss-javaee-6.0:3.0.2.Final:jboss-javaee-6.0.pom'
   > Could not parse POM http://repo.maven.apache.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-push-model/1.1.0-alpha.1/unifiedpush-push-model-1.1.0-alpha.1.pom
      > Could not resolve org.jboss.aerogear.unifiedpush:unifiedpush-push-parent:1.1.0-alpha.1.
         > Could not parse POM http://repo1.maven.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-push-parent/1.1.0-alpha.1/unifiedpush-push-parent-1.1.0-alpha.1.pom
            > Could not resolve org.jboss.aerogear.unifiedpush:unifiedpush-parent:1.1.0-alpha.1.
               > Could not parse POM http://repo1.maven.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-parent/1.1.0-alpha.1/unifiedpush-parent-1.1.0-alpha.1.pom
                  > Could not download artifact 'org.jboss.spec:jboss-javaee-6.0:3.0.2.Final:jboss-javaee-6.0.pom'
_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] gradle dependency issue with java client

avibelli
Hi Ronald,
this seems a bit strange, the dependencies should be resolved with no problems.

Could you try replacing:

 maven {
        url 'https://repository.jboss.org/nexus/content/repositories/'
    }
    maven {
        url 'http://repo1.maven.org/maven/'

    }
    maven {
        url 'http://repo.maven.apache.org/maven2/'
    }

with:

repositories {
    mavenCentral()
}

and see if this solves your issue?
If that does not work, could you send the whole script so that we can debug the issue?

Thanks
Andrea


Ronald van Aken wrote
Hi aerogear team,

I am having an issue that my gradle build file cannot find the 1.1.0
library (and dependencies) in the maven repositories as is outlined in the
dependency on github. When i try to use
the unifiedpush-java-client:1.1.0-alpha.1 i run into several dependency
errors in that it cannot find the model and j2ee-jboss libraries. (It
puzzles me why the library would require the j2ee libs but that is a
different question :)

Do you have any idea how i can best resolve this?

Thanks in advance!
Ronald.

I am using the following repository url's from a gradle script:

  maven {
        url 'https://repository.jboss.org/nexus/content/repositories/'
    }
    maven {
        url 'http://repo1.maven.org/maven/'

    }
    maven {
        url 'http://repo.maven.apache.org/maven2/'
    }

errors i am getting are:

org.jboss.aerogear:unifiedpush-java-client:1.1.0-alpha.1
      > Could not parse POM
http://repo1.maven.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-push-model/1.1.0-alpha.1/unifiedpush-push-model-1.1.0-alpha.1.pom
      > Could not resolve
org.jboss.aerogear.unifiedpush:unifiedpush-push-parent:1.1.0-alpha.1.
            > Could not parse POM
http://repo1.maven.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-push-parent/1.1.0-alpha.1/unifiedpush-push-parent-1.1.0-alpha.1.pom
            > Could not resolve
org.jboss.aerogear.unifiedpush:unifiedpush-parent:1.1.0-alpha.1.
                  > Could not parse POM
http://repo1.maven.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-parent/1.1.0-alpha.1/unifiedpush-parent-1.1.0-alpha.1.pom
                  > Could not download artifact
'org.jboss.spec:jboss-javaee-6.0:3.0.2.Final:jboss-javaee-6.0.pom'
                     > Could not HEAD '
http://repo.ont.powerhouse.local:18080/content/groups/local/org/jboss/spec/jboss-javaee-6.0/3.0.2.Final/jboss-javaee-6.0-3.0.2.Final.pom
'.
                        > repo.ont.powerhouse.local
               > Could not parse POM
http://repo.maven.apache.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-parent/1.1.0-alpha.1/unifiedpush-parent-1.1.0-alpha.1.pom
                  > Could not download artifact
'org.jboss.spec:jboss-javaee-6.0:3.0.2.Final:jboss-javaee-6.0.pom'
               > Could not parse POM
http://repo1.maven.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-parent/1.1.0-alpha.1/unifiedpush-parent-1.1.0-alpha.1.pom
                  > Could not download artifact
'org.jboss.spec:jboss-javaee-6.0:3.0.2.Final:jboss-javaee-6.0.pom'
               > Could not parse POM
http://repo.maven.apache.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-parent/1.1.0-alpha.1/unifiedpush-parent-1.1.0-alpha.1.pom
                  > Could not download artifact
'org.jboss.spec:jboss-javaee-6.0:3.0.2.Final:jboss-javaee-6.0.pom'
   > Could not parse POM
http://repo.maven.apache.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-push-model/1.1.0-alpha.1/unifiedpush-push-model-1.1.0-alpha.1.pom
      > Could not resolve
org.jboss.aerogear.unifiedpush:unifiedpush-push-parent:1.1.0-alpha.1.
         > Could not parse POM
http://repo1.maven.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-push-parent/1.1.0-alpha.1/unifiedpush-push-parent-1.1.0-alpha.1.pom
            > Could not resolve
org.jboss.aerogear.unifiedpush:unifiedpush-parent:1.1.0-alpha.1.
               > Could not parse POM
http://repo1.maven.org/maven2/org/jboss/aerogear/unifiedpush/unifiedpush-parent/1.1.0-alpha.1/unifiedpush-parent-1.1.0-alpha.1.pom
                  > Could not download artifact
'org.jboss.spec:jboss-javaee-6.0:3.0.2.Final:jboss-javaee-6.0.pom'

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Loading...