Quantcast

[Aerogear-users] mobile SDKs keeping connections open?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Aerogear-users] mobile SDKs keeping connections open?

Yoann Archambault
Hi,

We migrated to Aerogear recently and now that our app is live, we are seeing 1000s of established TCP connections coming from our devices (Average of 1.5 connection per remote IP).

I would expect the SDK to create a connection to register and the close it. Same for the "opened" metrics request.

I've had to increase the maximum number of opened file descriptors for the wildfly user but i don't see this as a proper long term solution.

Or am i missing something and somehow this is the expected behavior?

- Aerogear server version is 1.1.3.Final
- Although i am unable to confirm 100%, i think this issue happens on both ios and android SDKs.

--
Yoann

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] mobile SDKs keeping connections open?

Summers Pittman


On Wed, Aug 17, 2016 at 1:10 PM, Yoann Archambault <[hidden email]> wrote:
Hi,

We migrated to Aerogear recently and now that our app is live, we are seeing 1000s of established TCP connections coming from our devices (Average of 1.5 connection per remote IP).

I would expect the SDK to create a connection to register and the close it. Same for the "opened" metrics request.

I've had to increase the maximum number of opened file descriptors for the wildfly user but i don't see this as a proper long term solution.

Or am i missing something and somehow this is the expected behavior?

This isn't expected behavior.  Do you have a public repository we can take a look at?  We've never seen this behavior before.
 

- Aerogear server version is 1.1.3.Final
- Although i am unable to confirm 100%, i think this issue happens on both ios and android SDKs.


What version of the client SDKs are you using?
 
--
Yoann

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users



_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Loading...