[Aerogear-users] [newbie] choosing the right version

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Aerogear-users] [newbie] choosing the right version

pcasar
Hi,

   I would like to use aerogear-unifiedpush-server to generate some push messages between the e-learning web platform I'm developing and its iOS app. First I deployed aerogear-unifiedpush-server 1.2.0.alpha3 on a EC2 vm I owned and than I configured my iOS app (objective-c) to use it, but I came across some issues dealing with APNs: soon after I ask to send a push message to one of my registered devices, the APNs tells Aerogear to disable the device.

Now I have seen that there is a new version (1.2.0.beta1), do you suggest me to move to this version? or it's better to use the 1.1.0.Final? Is it possible to use the objective-c sdk with 1.2.x server?

Thanks in advance,
   Paolo.
--
Paolo Casarini
Digital development manager
Società editrice il Mulino S.p.A.
Strada maggiore 37 - 40125 Bologna
tel. 051/256011; fax 051/256034
GPG key: 1024D/9C5AE886 2004-10-21 Paolo Casarini <[hidden email]>

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] [newbie] choosing the right version

Matthias Wessendorf


On Mon, May 29, 2017 at 11:56 AM, Paolo Casarini <[hidden email]> wrote:
Hi,

   I would like to use aerogear-unifiedpush-server to generate some push messages between the e-learning web platform I'm developing and its iOS app. First I deployed aerogear-unifiedpush-server 1.2.0.alpha3 on a EC2 vm I owned and than I configured my iOS app (objective-c) to use it, but I came across some issues dealing with APNs: soon after I ask to send a push message to one of my registered devices, the APNs tells Aerogear to disable the device.

Now I have seen that there is a new version (1.2.0.beta1), do you suggest me to move to this version?

I'd use that beta1

regarding the disabled devices... I am not sure what you are asking about 
 
or it's better to use the 1.1.0.Final? Is it possible to use the objective-c sdk with 1.2.x server?

Thanks in advance,
   Paolo.
--
Paolo Casarini
Digital development manager
Società editrice il Mulino S.p.A.
Strada maggiore 37 - 40125 Bologna
tel. <a href="tel:05125%206011" value="+4951256011" target="_blank">051/256011; fax <a href="tel:05125%206034" value="+4951256034" target="_blank">051/256034
GPG key: 1024D/9C5AE886 2004-10-21 Paolo Casarini <[hidden email]>

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users




--

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Aerogear-users] [newbie] choosing the right version

Julio Cesar Sanchez Hernandez
In reply to this post by pcasar
Hi,

The Objective-C sdk should work with any UPS version.

If APNs tells Aerogear to disable the device it's because APNs doesn't recognize the device push token. That might happen when the app is in debug mode (like when you run it from Xcode), but you uploaded the production push certificate to UPS and/or you are using production mode in the variant.


On Mon, May 29, 2017 at 11:56 AM, Paolo Casarini <[hidden email]> wrote:
Hi,

   I would like to use aerogear-unifiedpush-server to generate some push messages between the e-learning web platform I'm developing and its iOS app. First I deployed aerogear-unifiedpush-server 1.2.0.alpha3 on a EC2 vm I owned and than I configured my iOS app (objective-c) to use it, but I came across some issues dealing with APNs: soon after I ask to send a push message to one of my registered devices, the APNs tells Aerogear to disable the device.

Now I have seen that there is a new version (1.2.0.beta1), do you suggest me to move to this version? or it's better to use the 1.1.0.Final? Is it possible to use the objective-c sdk with 1.2.x server?

Thanks in advance,
   Paolo.
--
Paolo Casarini
Digital development manager
Società editrice il Mulino S.p.A.
Strada maggiore 37 - 40125 Bologna
tel. 051/256011; fax 051/256034
GPG key: 1024D/9C5AE886 2004-10-21 Paolo Casarini <[hidden email]>

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users



_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Loading...