Android - how to compile with latest version of Googe Play services

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Android - how to compile with latest version of Googe Play services

Francois
Hello,

In the current version of the cordova plugin, google play services v6.1.11 is being used (see gradle dependencies output)

+--- org.jboss.aerogear:aerogear-android-push:2.2.2
|    +--- org.jboss.aerogear:aerogear-android-core:2.1.0
|    +--- org.jboss.aerogear:aerogear-android-pipe:2.1.0 (*)
|    +--- com.google.android.gms:play-services:6.1.11
|    \--- com.google.code.gson:gson:2.2.2

The project I am working on also needs google maps and location services and both cordova plugins require google play services v8.4.0.

Is there a way to mix both google play versions and successfully compile the whole project ?

the output of the compile task is as follow:
> Error: more than one library with package name 'com.google.android.gms'

Thanks for your help
Reply | Threaded
Open this post in threaded view
|

Re: [Aerogear-users] Android - how to compile with latest version of Googe Play services

Summers Pittman
You can exclude the com.google.android.gms group from the aerogear push dependency.

compile('org.jboss.aerogear:aerogear-android-push:2.2.2') {
    exclude group: "com.google.android.gms"
}

On Thu, Feb 18, 2016 at 11:42 AM, Francois <[hidden email]> wrote:
Hello,

In the current version of the cordova plugin, google play services v6.1.11
is being used (see gradle dependencies output)

+--- org.jboss.aerogear:aerogear-android-push:2.2.2
|    +--- org.jboss.aerogear:aerogear-android-core:2.1.0
|    +--- org.jboss.aerogear:aerogear-android-pipe:2.1.0 (*)
|    +--- com.google.android.gms:play-services:6.1.11
|    \--- com.google.code.gson:gson:2.2.2

The project I am working on also needs google maps and location services and
both cordova plugins require google play services v8.4.0.

Is there a way to mix both google play versions and successfully compile the
whole project ?

the output of the compile task is as follow:
> Error: more than one library with package name 'com.google.android.gms'

Thanks for your help



--
View this message in context: http://aerogear-users.1116366.n5.nabble.com/Android-how-to-compile-with-latest-version-of-Googe-Play-services-tp513.html
Sent from the aerogear-users mailing list archive at Nabble.com.
_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users


_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users
Reply | Threaded
Open this post in threaded view
|

Re: [Aerogear-users] Android - how to compile with latest version of Googe Play services

Francois
thank you Summers. it is working fine now.

for anyone having this issue, here is the full aerogear cordova gradle configuration:

android {
  packagingOptions {
    exclude 'META-INF/maven/com.madgag/scprov-jdk15on/pom.properties'
    exclude 'META-INF/maven/com.madgag/sc-light-jdk15on/pom.properties'
    exclude 'META-INF/maven/com.madgag/scprov-jdk15on/pom.xml'
    exclude 'META-INF/maven/com.madgag/sc-light-jdk15on/pom.xml'
  }
}

dependencies {
    compile 'com.android.support:appcompat-v7:22.+'
    compile 'org.jboss.aerogear:aerogear-android-core:2.1.0'
    compile 'org.jboss.aerogear:aerogear-android-pipe:2.1.0'
    compile 'org.jboss.aerogear:aerogear-android-store:2.1.0'
    compile ('org.jboss.aerogear:aerogear-android-push:2.2.2') {
      exclude group: 'com.google.android.gms'
    }
   compile 'com.google.android.gms:play-services-gcm:8.4.0'
}

Summers Pittman wrote
You can exclude the com.google.android.gms group from the aerogear push
dependency.

compile('org.jboss.aerogear:aerogear-android-push:2.2.2') {
    exclude group: "com.google.android.gms"
}

On Thu, Feb 18, 2016 at 11:42 AM, Francois <[hidden email]> wrote:

> Hello,
>
> In the current version of the cordova plugin, google play services v6.1.11
> is being used (see gradle dependencies output)
>
> +--- org.jboss.aerogear:aerogear-android-push:2.2.2
> |    +--- org.jboss.aerogear:aerogear-android-core:2.1.0
> |    +--- org.jboss.aerogear:aerogear-android-pipe:2.1.0 (*)
> |    +--- com.google.android.gms:play-services:6.1.11
> |    \--- com.google.code.gson:gson:2.2.2
>
> The project I am working on also needs google maps and location services
> and
> both cordova plugins require google play services v8.4.0.
>
> Is there a way to mix both google play versions and successfully compile
> the
> whole project ?
>
> the output of the compile task is as follow:
> > Error: more than one library with package name 'com.google.android.gms'
>
> Thanks for your help
>
>
>
> --
> View this message in context:
> http://aerogear-users.1116366.n5.nabble.com/Android-how-to-compile-with-latest-version-of-Googe-Play-services-tp513.html
> Sent from the aerogear-users mailing list archive at Nabble.com.
> _______________________________________________
> Aerogear-users mailing list
> [hidden email]
> https://lists.jboss.org/mailman/listinfo/aerogear-users
>

_______________________________________________
Aerogear-users mailing list
[hidden email]
https://lists.jboss.org/mailman/listinfo/aerogear-users